Difference between revisions of "Live GIS Disc Testing"

From OSGeo
Jump to: navigation, search
(ushahidi)
m (Mapbender)
Line 1,138: Line 1,138:
 
* next test will be run with the osgeolive 4.0 rc
 
* next test will be run with the osgeolive 4.0 rc
 
----
 
----
 +
;test results from 23.7.2010
 +
:Run by: Marc Manns
 +
:System: VirtualBox, 2Gig RAM, on ubuntu 8.10
 +
:Version: OSGeoLIve beta2 Mapbender 2.6.1
 +
:Results: Pass with issues
  
 +
* create user/group
 +
* create application
 +
* register new WMS
 +
* customize tree
 +
* add WMSFromFilteredList
 +
* change language in [Mapbender.conf] to german
 +
 +
* suggestion: There is a password.txt at the desktop. I think, we should add our root/root authentication to it. -> '''done --[[User:Astrid Emde|astroide]] 09:28, 23 July 2010 (UTC) '''
 +
 +
; Result
 +
* the Mapbender applications handling worked fine
 +
 +
----
 
;Add more test results below, most recent results at the top
 
;Add more test results below, most recent results at the top
  
 
<br>
 
<br>
 
  
 
= Ushahidi =
 
= Ushahidi =

Revision as of 01:28, 23 July 2010

This page describes how to test each application installed on the Live GIS Disc. Application test steps describe how an Ubuntu user who is unfamiliar an application can try it out and confirm that everything has been installed correctly within 5 minutes. Test Results document when the application was last verified to be working.

This page is maintained at: http://wiki.osgeo.org/wiki/Live_GIS_Disc_Testing and copied onto each release of the LiveDVD.

  • Please try to move the app list into more of an alphabetical order ...

template

Tests written for
.package. [version], arramgong [version]
Test Description last updated
.date.
Steps

Ideally, steps will reference Quick Start documentation, otherwise use following:

  • .action.
Verify that ...
  • Eg: From menu, select GeoSpatial->Application->Start
Eg: Verify that a browser opens at url: http://localhost:... and shows the application start page.
  • Update the wiki with test results (after these test steps)

test results from .date.
Run by: FirstName LastName
System: VMWare Player, 2Gig RAM, on ubuntu 9.0 base
Version: distribution version: eg: arramagong 3.0 rc2
Results: Pass, Pass with issues, Fail
  • link to bug reports

Add more test results below, most recent results at the top


geopublishing (geopublisher and atlasstyler)

Tests written for
Geopublisher and AtlasStyler 1.4, Arramgong 3.0rc5
Test Description last updated
12.03.2010
Steps

  • Go to applications->education-> and open Geopublishing documentation
    • Verify that the green page from file:///usr/share/doc/geopublishing/index.html open in a browser
  • Scroll to the bottom and click the demo atlas.
  • Unzip it do your Desktop
  • Go to applications->education-> and start Geopublisher
  • Load the atlas.gpa from your Desktop/ChartDemoAtlas
    • Verify that Geopublisher load the atlas. You should see a triparted GUI with a map-pool, data-pool and menu area.
  • Select File->Export and follow the wizard..
    • export online and offline version of the atlas to a new directory Desktop/ChartAtlasExported
    • When the export has finished, click the "open folder" button
    • Close Geopublisher
  • Go into the Desktop/ChartAtlasExported/DISK folder and run start.sh
    • Verify that an atlas opens
    • Verify that you see a "Charts available" button at the top right
    • Verify that clicking selecting the chart opens a chart window

Let that be the basic testing for Geopublisher now.


test results from 16 March 2010
Run by: Stefan Tzeggai
System: kvm, 600Mb RAM, on ubuntu 9.10 base
Version: arramagong 3.0 rc5
Results: Pass with issues. Two minor problems:
  • after export the "open folder" button doesn't work, because xubuntu doesn't support that java desktop integation. but the folder can be openen manually.
  • Second problem is, that start.sh has to be set executable manually after export.

geoserver

Tests written for
GeoServer 2.0.1, arramagong 3.0rc4
Test Description last updated
13 March 2010
Steps
  • Select the "Start GeoServer" icon.
  • Wait ~ 60 seconds for GeoServer to start.
Verify the GeoServer web page opens at http://localhost:8082/geoserver/web
  • In the firefox browser, click on "Layer Preview", wait ~ 30 secs
Verify you get a list of map layers
  • Select the 'OpenLayers' link on one of the layers (say the TOPP:States)
Verify you should see a web page with sample data in an interactive map

test results from 13 March 2010
Run by: Cameron Shorter
System: VMWare Player, 2Gig RAM, on ubuntu 9.10 base
Version: arramagong 3.0 rc4
Results: Pass

gvSIG

Tests written for
gvSIG 1.9 (BN1253), arramgong 3.0rc2
Test Description last updated
2010/03/10
Steps

  • Go to applications->education and start gvSIG
Verify that gvSIG starts correctly
  • Create a new view and add some shapefiles from /usr/local/share/mapserver/demos/itasca/data
Verify that the shapefiles are correctly added to the view
  • Create a new view and add any of the two TIFF files from /usr/local/share/mapserver/demos/itasca/data
Verify that the raster files are correctly loaded to the view
  • If you have Internet access, try to add a WMS layer from the combo list (i.e. the NASA JPL server)
Verify that a WMS layer can be accessed
  • Open the sample project included in the LiveDVD at /usr/local/share/gisvm/app-data/gvsig/sample-project.gvp
Verify the project loads all the data and layouts configured are available.
  • You can also try to access any of the other data available from the LiveDVD like the PostGIS Data, or WxS services by the map servers configured
This tests are related with the correct functioning of the other software installed on the LiveDVD
  • Update the wiki with test results (after these test steps)

test results from 2010/03/10
Run by: Jorge Sanz
System: Sun Virtual Box 3.1.4, with 700MB RAM for the VM
Version: distribution version: arramagong 3.0 rc2
Results: Passed all tests, well I wrote them at this session ;-)

geomajas

Tests written for
Geomajas 1.4.2, arramagong 2.0/3.0-rc2
Test Description last updated
9 March 2010
Steps

  • Click desktop icon "Start Geomajas" which will start the Geomajas startup script. This will in turn start up a Tomcat server.
Verify firefox opens a new tab at the page http://localhost:3420/geomajas-tutorial/applications/tutorial/html/
  • Click on the "Start demo!" link for the Attributes & Features demo.
Verify that a sample demo page has opened with an application, showing the provinces of Belgium.
  • Doubleclick on one of the rows in the attribute table bottom right.
Verify that a floating window appears, showing the rows' contents in more detail.
  • Click on the desktop icon "Stop Geomajas".
Verify that the Tomcat server that runs Geomajas has stopped.
  • This can be done by refreshing the page. Firefox should give a warning that it is unable to connect.
test results from 9 March 2010
Run by: Pieter De Graef
System: Virtualbox, ~512MB RAM, on Windows XP
Version: distribution version: arramagong-3.0rc2
Results: Pass

geonetwork

Tests written for
Geonetwork, LiveDVD 3.0
Test Description last updated
14 March 2010
Steps

  • Click icon "Start Geonetwork" - wait until the server intializes (see load graph in the upper right hand corner)
  • open FireFox http://localhost:8880
  • you should see a list of active URLs, choose /geonetwork
Result
  • see the opening page of the Geonetwork server

deegree

Tests written for
deegree 2.3, arramagong 2.0/3.0-rc2
Test Description last updated
25 June 2010
Steps

  • Click desktop icon "start deegree" which will run "catalina.sh start".
Verify firefox opens a new tab at the page http://localhost:8081/
  • Click the service links ("deegree-wms", "deegree-wfs", "deegree-wcs") in top left box ("deegree Web Applications").
Verify they open test pages for WMS, WFS, and WCS. These pages will contain links to
  • "GetCapabilities" (for each of the services)
  • "Test WMS", "Test WFS" or "Test WCS" (depending on the chosen service)
  • a link for the "Generic Client", a client for sending XML requests (http post) to the services.
  • Click on "TestW*S"
Verify you get either maps or xml fragments.
  • TestWMS will contain some images (results of WMS requests), and links for further KVP requests (http get).
  • TestWFS will open a page with several links for WFS requests (KVP). Either one will return XML fragments. There is also a link to the generic client.
  • TestWCS will open a page with several links for WCS requests (KVP). Either one will return XML fragments.
  • Click the client link ("deegree iGeoPortal") in top left box ("deegree Web Applications").
Verify this will open a new tab with a list of available WebMapContexts. Either one of these links (Utah, SaltLakeCity or Playground) should open a full working portal in this tab. Once the WMC is loaded you may switch to the other WMCs by using the drop down box labled "Theme selection"
  • Click on the desktop icon "stop deegree"
Verify the deegree-tomcat process is stopped.
  • click any of the links previously used: you will get a "Failed to Connect" message from firefox.
  • open a terminal and try ps fax | grep deegree. You should not get any results other than the grep itself.
  • Update the wiki with test results (after these test steps)

test results from 4 March 2010
Run by: Judit Mays
System: Virtualbox, ~600MB RAM, on ubuntu 9.0 base
Version: distribution version: arramagong-3.0rc2
Results: Pass

kosmo

Tests written for
Kosmo 2.0 RC1, LiveDVD 3.0
Test Description last updated
18 March 2010

Theming layer with PostGIS backend
  • Select Geospatial > Desktop GIS > Kosmo in order to start Kosmo - Desktop
  • In the welcome dialog, select the option "With a new view" inside the "Create a new project" panel and click Ok
  • In the "Spatial Reference System selection" dialog, press the "..." button in order to select the view SRS
  • Select "EPSG" as Type
  • Enter 2270 in the textfield and click "Search" button; select the CRS given and click the Ok button
  • Click Ok again to set EPSG:2270 as the current view projection
  • In the main menu "View", select the option "Load Dataset..."
  • Select as Format -> "Database" (at the top-left corner) and "PostGIS" as database type
  • Enter Database Name: medford User Name: user Password: user and click the "Connect" button
  • Scroll down, check the box to the left of public.medford_zoning and click the Ok button
  • Select the medford_zoning layer at left under 'Working' and click the checkbox to make it visible
  • Right-click on the 'medford_zoning' layer and choose Simbology > Change Styles...
  • Select the "Colour Theming" tab; click the "Enable colour theming" checkbox
  • Choose Attribute => zoning and click the Ok button to apply the changes
  • You should see the zoning areas of Medford coloured by attribute in the map


Shapefile and image loading

  • Select Geospatial > Desktop GIS > Kosmo in order to start Kosmo - Desktop
  • In the welcome dialog, select the option "With a new view" inside the "Create a new project" panel and click Ok
  • Repeat the steps described in the test "Layer Theme with PostGIS backend", but selecting EPSG:26915 as the view projection
  • In the main menu "View", select the option "Load Dataset..."
  • Select as Format -> "Image file" and navigate to /home/user/data/mapserver/demos/itasca/ (or data/mapserver/demos/itasca/ if it starts at the home/user directory)
  • Select the directory "data" in order to load all the tiffs inside it as a mosaic and press the Ok button
  • Select the data layer at left under 'Working' and click the checkbox to make it visible
  • Select as Format -> "Shapefile" and navigate inside data directory
  • Select all the shapefiles and press the Ok button in order to load them
  • Check that all the shapefiles have been loaded on the layer tree at the left. Make them visible by clicking on the checkbox of each one



test results from 18 March 2010
Run by: Sergio Baños
System: VirtualBox 3.1.4 with Guest additions, 3Gb RAM, on Windows Vista
Version: 3.0 rc5
Results: Pass


udig

Tests written for
udig , arramgong 3.0rc5
Test Description last updated
18 March 2010
Steps
  • open UDig
Verify you see a Welcome screen
  • Close the Welcome display. (Note if you don't close this display, then you can't load layers later on)
  • from the Layer menu, choose "Add..."
  • Choose Files from /home/user/data/udig/udig-data/data-v1_2/
  • select bc_border.shp
  • you may also select others, for example all shp files starting with bc_
  • click OK
Verify you see Canadian British Columbia data

test results from 14 March 2010
Run by: Cameron Shorter
System: VMWare Player, 2Gig RAM, on ubuntu 9.10 base
Version: distribution version: arramagong 3.0 rc4
Results: Pass with issues
  • Pass with issues:
    • If the Welcome screen is not closed, then trying to load a shapefile as described takes the user to a rolling "loading" icon, and message "Adding layers to map" however, it doesn't progress past this.

openjump

Tests written for
OpenJUMP, arramagong 2.0/3.0-rc2
Test Description last updated
8 March 2010

Layer Theme with PostGIS backend
  • Open OpenJUMP
  • under the File menu select 'Open...'
  • select Data Store Layer
  • on the Connection line, click on the database icon (far right)
  • click on Add
  • enter Name: medford Server: localhost Port: 5432 Instance: medford User: user Password: user
  • click OK; click OK in the parent dialog box; you should be back in the Data Store Layer dialog
  • from the Dataset: menu choose 'medford_zoning'; click Finish
  • select the medford zoning layer at left under 'Working'
  • click on the Palette Icon in the menu bar
  • select the 'Colour Theming' tab; click 'Enable colour theming' checkbox
  • choose Attribute => zoning
  • choose a colour theme; click 'OK' to dismiss the dialog
  • you should see the zoning areas of Medford in various colours

postgis

Tests written for
PostGIS, arramagong 2.0/3.0-rc2
Test Description last updated
4 March 2010

Spatial Query with the Graphical Query Builder helper
  • Open PGAdmin III from the Development menu
  • double-click on 'local'
  • under Databases, double-click on medford
  • open 'schemas'
  • open 'public'
  • select 'Tables', click on the 'Execute SQL' Icon above (it has a pencil in it)
  • expand the window and click on 'Graphical Query Builder'
  • open 'Schemas', double-click on 'public'
  • click and drag 'medford_wards' to the work area on the right
  • click and drag 'jacksonco_schools' to the work area on the right
  • choose 'jacksonco_schools' name, address, city and students
  • choose 'medford_wards' council_me (meaning council members)
  • click and drag from the_geom in 'medford_wards' to the_geom in 'jacksonco_schools' (you should see a solid line form with an '=' in it)
  • click on the 'SQL Editor' tab above, to navigate away from the Graphical Query Builder
  • edit the WHERE line to say
 ST_Contains( medford_wards.the_geom, jacksonco_schools.the_geom )
  • add an additional line
 ORDER BY medford_wards.council_me, jacksonco_schools.students DESC;
  • the entire query ends with one semicolon ';'
  • click on the 'execute query' icon above (a green triangle pointing to the right) you should see a list of council districts, schools, school sizes and the names of council members for each district as a result



test results from 4 March 2010
Run by: Brian Hamlin
System: Virtualbox, 1024mb RAM, on debian 5.03 base
Version: distribution version: arramagong-3.0rc2
Results: user tested, passed in less than 5 minutes with no previous experience


New Database
$ createdb -T template_postgis osm_barcelona
$ osm2pgsql -d osm_barcelona  /usr/local/share/osm/Barcelona.osm.bz2

Then try to view it in QGIS.

spatialite

Tests written for
spatialite, LiveDVD 3.0
Last updated
14 March 2010
Steps

  • Open a terminal
spatialite /usr/local/share/spatialite/regions.sqlite
select r.NOME_REG, a.Nome from Aeroporti a, reg2008_s r where CONTAINS( r.Geometry, a.Geometry ) order by r.NOME_REG;
a graphical view of the same data
  • Run spatialite-gis

open file /usr/local/share/spatialite/regions.sqlite

Result - test please

You should see a set of Airports in Italy

pgrouting

Tests written for
pgRouting SVN trunk revision 356, arramagong 2.0/3.0
Last updated
March 2010
Steps

  • Open a terminal
sudo -u user psql -c "SELECT gid, AsText(the_geom) AS the_geom FROM dijkstra_sp_delta('sydney', 101, 114, 0.003)"  sydney
sudo -u user psql -c "SELECT gid, AsText(the_geom) AS the_geom FROM astar_sp_delta('sydney', 101, 114, 0.003)"  sydney
sudo -u user psql -c "SELECT gid, AsText(the_geom) AS the_geom FROM shootingstar_sp('sydney', 8, 24, 0.1, 'length', true, true)"  sydney

After each command you should see some output which is not hopefully 'library not found' error.

osm

JOSM
  • File → Open → /usr/local/share/osm/Barcelona.osm.bz2
Gosmore
  • Open a terminal
  • Import data with:
bzip2 -dc /usr/local/share/osm/Barcelona.osm.bz2 | gosmore rebuild

mapserver

Tests written for
MapServer 5.6.3, OSGeo LiveDVD 4.0
Test Description last updated
30 June 2010
Steps
  • Select the "MapServer" icon.
  • Wait a few seconds for FireFox to start.
Verify the MapServer web page opens at file:///usr/local/share/livedvd-docs/doc/mapserver_description.html
  • In the firefox browser, scroll down to "MapServer Demo" section and click on "Itasca".
Select "Basic Application" and click on "Initialize".
Verify you get a map.
  • Select the "Query multiple features" tool on the right of the page and click somewhere on the map.
Verify you get a list of features.
  • THE GMAP DEMO HAS BEEN REMOVE IN 4.0 ALPHA4, IT IS NOT YET COMPATIBLE WITH PHP 5.3 Return to the the initial MapServer web page, file:///usr/local/share/livedvd-docs/doc/mapserver_description.html , scroll down to "MapServer Demo" section and click on "GMap".
Verify you get a map and a legend with icons rendered.
  • Return to the the initial MapServer web page, file:///usr/local/share/livedvd-docs/doc/mapserver_description.html on the initial MapServer web page, scroll down to "MapServer Documentation" section.
Verify that the documentation version is appropriate versus the MapServer version.

test results from 14 March 2010
Run by: Cameron Shorter
System: VMWare Player, 2Gig RAM, on ubuntu 9.0 base
Version: arramagong 3.0 rc4
Results: Pass with issues
  • Documentation refers to the older 5.4 version

geokettle

Tests written for
GeoKettle 3.2.0-20090609
Last updated
March 2010
Steps
  • Launch GeoKettle.
Verify you get a window prompting you to select a repository.
  • On the "Select a repository" dialog, choose "No repository".
Verify the GeoKettle application is opened.
  • Close any startup tips dialog.
  • Select File-> Open
  • Select /opt/geokettle/samples/transformations/geokettle/intersection.ktr
Verify you see the "intersection" transformation in the work area, with a big yellow comment box and some step icons.
  • Run the transformation in preview mode
    • Select Transformation menu -> Preview
    • Choose the "Intersecting rows" step (to view the rows that are outputted by that step)
    • then click on Quick Launch.
Verify you see the result in the "Examine preview data" dialog (two rows with four columns: GEOM1_ID, geom1, GEOM2_ID, geom2. The geom1 and geom2 fields should contain MULTIPOLYGON WKT geometries).

test results from 13 March 2010
Run by: Cameron Shorter
System: VMWare Player, 2Gig RAM, on ubuntu 9.10 base
Version: arramagong 3.0 rc4
Results: Pass

gmt

There are 29 example jobs built in, and a script to run them all:

  • Open a terminal
cp -r /usr/share/doc/gmt-examples/examples/ gmt-examples
cd gmt-examples/
./do_examples.sh

[whiz .. bang .. whirl]

View results: (type 'q' to quit gv)

for PLOT in `find . -name *.ps` ; do
   echo "$PLOT"
   gv "$PLOT"
done

Cleanup:

cd ..
rm -rf gmt-examples/

grass

Tests written for
grass 6.4.0rc5, arramagong 2.0/3.0
Last updated
March 2010
Steps

  • Double click on the GRASS desktop icon
Verify you see a slick "Welcome to GRASS" GUI
  • Select Spearfish60 for location, User1 for mapset
  • Click on [Start Grass]
  • In the Layer Manager GUI window add a raster layer
    • On the toolbar click the icon with a + and a checkerboard
    • On map to be displayed pull down the list and select elevation.dem
  • from the PERMANENT mapset and click [ok]
  • In the Layer Manager GUI window add a vector layer
    • On the toolbar click the icon with a + and a "V" line
    • For input map name pull down the list and select roads from the PERMANENT mapset and click [ok]
  • Over in the Map Display window toolbar click on the eyeball icon to render
Verify you see the maps displayed
See also
(North Carolina dataset is already installed in grassdata/)

test results from 14 March 2010.
Run by: John Tate
System: VirtualBox v3.0.8_OSE r53138, 2Gig RAM, on ubuntu 9.10 base
Version: arramagong vm 3.0 rc4
Results: Pass (including extended test at ...wiki/HowToTestGrass6)


qgis

FIXME
These instructions are not tested! Just off the top of my head.
open GeoTiff
  • where on the disc is one?
(if needed geotiff and shapefile export could be added to the GRASS testing procedure to make some)
open PostGIS data I
  • From the menu: Layer → Add PostGIS Layer ...
  • PostgreSQL Connections: [New]
    Name: medford
    Host: localhost
    Database: medford
    Port: 5432
    username: user
    password: user
    SSL Mode: allow
   Test Connect should show success
   select sample point, line and poly layers
   view selected data
open PostGIS data
(run the PostGIS test first so that the osm_barcelona DB exists!)
  • From the menu: Layer → Add PostGIS Layer ...
  • PostgreSQL Connections: [New]
Name: ________ "OpenStreetMap Import" 
Database: ____ "osm_barcelona"
  • Click on [Test Connect], with luck you will get a message that the connection to the database was successful.
  • Click [Ok] to close the New Database window.
  • Click on [Connect] in the top left of the Add PostGIS Table window. You should see a listing of tables come up.
  • Click on all of the table names to highlight them.
  • Click on [Add] at the bottom.
  • After some moments you should see the data displayed in the main map canvas.
  • Zoom, pan, query as you like.

This should at least prove to you that the database is correctly populated and running.

open shapefile
  • where on the disc is one?
  • From the menu: Layer → Add Vector Layer ...
Do not select New Vector Layer ... (that's for creating new data, not opening existing data)
  • Dataset: [Browse]
 ? where on disc ?
  • Ctrl-click on each of the *.shp files in that directory, then click [Open] and finally [Ok]
  • After some momements you should see the data displayed in the main map canvas.
  • Because the some of the shapefiles use a different map projection than the PostGIS database, things may not line up exactly. In the Settings → Projection Properties, Coordinate Reference System tab, you can tick the [•] Enable 'on the fly' CRS transformation box to overlay them. Be warned that this is computationally expensive and the layer may need to have its CRS set manually.
  • Zoom, pan, query as you like. Drag layer names up and down in the left-pane list to change their position in the stack.
open OSM data
  • need to enable plugin?
  • open /usr/local/share/osm/Barcelona.osm.bz2
Test the GRASS plugin
  • (it's installed, right?)
  • Go menu "Plugins, Pluginmanager, activate "GRASS plugin", OK button: a set of new buttons should appear
  • open location/mapset → ~/grassdata/spearfish90/PERMANENT
  • click "Add GRASS raster layer" button, select "elevation" map
  • click "Add GRASS raster layer" button, select "elevation_shade" map
  • click right mouse button in legend on "elevation_shade" map, move transparency to 40%
  • click "Add GRASS vector layer" button, select "roadsmajor" map, select layer "1-line" (level 1 is the topological level), OK

mapnik

see file:///usr/local/share/livedvd-docs/doc/mapnik_description.html Mapnik Description

maptiler

Tests written for
maptiler 1.0 all versions
Test Description last updated
11.3.2010
Steps

  • you need an GeoTIFF or other raster geodata to test the functionality. So download for example this: http://download.osgeo.org/gdal/data/gtiff/utm.tif (when you use Firefox it will automatically save the files into ~/Downloads).
  • start MapTiler: click on "Applications" -> "Graphics" -> "MapTiler"
  • in the MapTiler application select on the first page "Google Maps compatible" tiles and click "Continue"
  • in the second page of wizard add the tiff, it should be ~/Downloads/utm.tif and click "Continue"
  • continue trough all other steps in the wizard (default options are fine) and then start "Render"
  • when the rendering is finished you will see a link to the directory with tiles, click to open it (it opens in Firefox as a directory)
  • open the "googlemaps.html", you should see a black&white overlay displayed on top of Google Maps hybrid layer. You can also open "openlayers.html" to see another presentation of the results.
Verify that ...
  • MapTiler application starts without problems when clicked on the icon
  • When you press on "Render" applications starts the processing and does not report any error.

Alternative "real" geodata for testing are for example USGS maps or NOAA RNCs.


test results from 11.3.2010
Run by: Klokan Petr Pridal
System: VMWare Fusion, 512MB RAM in virtual machine, on MacOSX Leopard
Version: arramagong livedvd 3.0 rc4
Results: Pass

Another way to try it:

  1. Start MapTiler by clicking the icon on the Desktop
  2. Load in the second step example raster GEODATA (with georerence/srs)
  3. Go trough all the steps with 'Next' up to the Render
  4. Once the render is finished you can click in the GUI to open a folder with tiles. When you open googlemaps.html or openlayers.html then you see your geodata warped to the overlay of popular interactive web maps as Google Maps.

The map tiles are displayed directly from your disk. To publish the map to Internet just upload the folder with tiles to any webserver or Amazon S3"

marble

Tested against ver 2.0
  • Click on the desktop icon
  • If you have used Google Earth before you should be able to figure this one out without much difficulty.
  • In the Settings menu select full-screen mode
  • Explore ...
  • In the bottom-left corner of the program window there is a subtle tab called "Map View". Click on it.
  • Select another map (e.g. 'Precipitation (July)')
  • Explore some more ...

octave

  • Open a terminal
  • Start program by typing "octave" at the prompt
% Which way to Barcelona from Sydney?
sydney = [-33.8750 151.2005]
barcelona = [41+23/60 2+11/60]

dirn = azimuth(sydney, barcelona);
deg_symb = 176;
disp(['Heading: ' num2str(dirn) deg_symb])
% How far's the trip? (roughly!)
system('proj -le')
wgs84_a = 6378137.0  % major radius of the Earth, in meters
dist_deg = distance(sydney, barcelona)
dist_meters = pi * wgs84_a * (dist_deg / 360.0)
disp(['Distance: ' num2str(dist_meters / 1000) ' km'])

Type "exit" to quit.

opencpn

Activate data
  • Open a terminal
  • Type "opencpn_noaa_agreement.sh" at the prompt
Run program

(assuming your GPS is not plugged in and gpsd is not running)

  • Double click the OpenCPN icon on the desktop or type "opencpn" at a terminal
  • Left-click recenters the view
  • Left-click-drag pans the view
  • Mouse-wheel zooms in/out
  • The blue bars in the bottom show previews of overlapping maps and clicking on them switches to them.
More details in the on-disc help page
and specifically the Getting Started help page.

gpsdrive

Testing

If no GPS is plugged in

  • Double click on the GpsDrive desktop icon
  • You should see a map of downtown Sydney, after about 10 seconds a waypoint marker for the Convention Centre should appear.
  • Set the map scale to 1:10,000 either by dragging the slider at the bottom or by using the +,- buttons (not magnifying glass)
  • Enter Explore Mode by pressing the "e" key or in the Map Control button.
  • Use the arrow keys or left mouse button to move off screen.
  • Right click to set destination and leave Explore Mode
Downloading maps
  • Change the scale setting to 1:1,000,000 you should see a continental map
  • Enter Explore Mode again ("e") and left click on the great barrier reef
  • Options -> Map -> Download
    • Map source: NASA LANDSAT, Scale: 1:500,000, [Download Map]
    • When download is complete click [ok] then change the preferred scale slider to 1:500,000
    • This will be of more use in remote areas.
  • Explore to the coast, click on an airport, headland, or some other conspicuous feature. You might want to use the magnifying glass buttons to zoom in on it better. Use a right click set the target on some other conspicuous feature nearby then demagnify back out.
  • Options -> Map -> Download
    • Map source: OpenStreetMap, Scale: 1:150,000, left-click on map to center the green preview over your target and what looks like a populated area.
    • [Download Map]
    • When download is complete click [ok] then change the preferred scale slider to 1:150,000 and you should see a (rather rural) road map. This will be more interesting in built up areas.
Overlay a GPX track
  • In the ~/.gpsdrive/tracks/ directory you will find australia.gpx which is a track line following the coastline.
  • Options -> Import -> GPX track
  • Hidden folders are hidden in the file picker, but just start typing ~/.gpsdrive and hit enter. You should then see the tracks/ directory and be able to load australia.gpx.
  • A red trace should appear along the coastline.
  • Check that it lines up well with the coast as shown in map tiles of varying scale.

If a GPS is plugged in

  • Make sure gpsd is running by starting "xgps" from the command line.
  • The program will automatically detect gpsd and jump to your current position. This should bring up a continental map as you won't have any map tiles downloaded for your area yet.
  • See the above "Downloading Maps" section to get some local tiles.
  • If you have a local GPX track of some roads try loading that and making sure everything lines up, as detailed in the above "Overlay a GPX track" section.

That's it.

mb-system

  • Open a terminal
cd /usr/local/mbsystem/examples/

List summary information about the contents of some bathymetric data files:

cd mbinfo/
./mbinfo.cmd

Grid some sample data and then view it:

cd ../mbm_plot/
./mbm_plot_5.cmd

# which creates this script:
./mbm_plot_test5.cmd

You should now see a nice plot of the seafloor off Baja California.

  • (this also acts as a test of the GMT plotting package)

mapfish

Tests written for
mapfish 1.2, arramgong 3.0
Test Description last updated
2 April 2010
Steps

  • Make sure you have a working internet connection
  • Double click on the Mapfish icon on the desktop
Verify that a browser opens after a few seconds showing a map of the southwestern pacific
  • Click the magnifying glass just under the word "Map" at the top of the map.
  • Zoom in on Sydney
  • Explore

test results from 2 April 2010
Run by: Cameron Shorter
System: VMWare Player, 2Gig RAM, on windows XP base
Version: arramagong 3.0
Results: Pass with issues
  • The application requires an internet connection to work. The liveDVD should work without an internet connection, so it should access maps from a local WMS or similar.
  • The application doesn't show off any of the mapfish server functionality, making it difficult to sell its benefits over Openlayers.

R

  • double click on the R Icon
  • at the command line, type demo(graphics) and hit return
  • follow the prompt and watch the target window for examples

If it is possible please add steps here to test the included geostats packages, they are both more interesting and more likely to have problems in the build. tx

e.g. something with r-cran-maps(.deb), gstat, sp, rgdal, or spgrass6 ?
#Load a library
library(sp)
#list the demos available
demo()
#Run the demo from the sp package
#This will step you through several examples of code and the resulting plots
demo(gallery)


Some examples to try here:

http://r-spatial.sourceforge.net/xtra/xtra.RHnw.html

ossim

Tests written for
Ossim 1.8, arramagong 3.0rc4 + fixes
Test Description last updated
16 March 2010
Steps
Imagelinker
  • Start Imagelinker from its icon from the directory "Spatial Tools" on the desktop
  • Select the project file, using File -> Open Project -> /home/user/data/ossim/ossim_data/landsatrgb.prj
  • Go to the menu bar -> window -> tile
  • Select an image window -> select the pan icon -> click on the image -> press the button "propagate"
  • Verify you see a 3 gray satelite images.
OssimPlanet
  • Start OssimPlanet from its icon from the directory "Desktop-GIS" on the desktop
  • Select File -> Open Session -> /home/user/ossim/ossim_data/session.session
  • Navigate the scene.
  • Go to menu -> Open kml -> /home/user/ossim/ossim_data/*.kml
  • Go on the legend tree -> location -> open the trees -> bouble click on the kml location
you should see the scene zoom to the location
  • To test the command line simply run :
   ossim-image-info /usr/local/share/ossim/ossim_data/band1.tif

Note: to turn off the daylight auto-shading, un-check Preferences -> Environment -> Enable Ephemeris


test results from 16 March 2010
Run by: Cameron Shorter
System: VMWare Player, 2Gig RAM, on ubuntu 9.10 base
Version: distribution version: eg: arramagong 3.0 rc4 + fixes
Results: Pass with issues
  • Imagelinker: These test steps don't give guidance on how to try some of the functionality
  • Imagelinker: Tried opening a project, then opening the project a second time and the application crashed

ugvsigmobile

Tests written for
Unofficial gvSIG Mobile for Linux 0.1.6, arramagong 3.0-rc4
Test Description last updated
13 March 2010
Steps
  • Click menu icon "Applications / Geospatial Beta software / Unofficial gvSIG Mobile for Linux".
Verify a new window opens up (size: 800 x 600 pixels approx.). From now on, buttons on the left side will be called (from top): button 1, button 2, button 3, button 4, button 5 and button 6. Button 1 is a cycle button with four different states corresponding to four different tools, so that active tool is the visible one.
  • Click button 5 and choose EPSG:25833 in the top combo box.
  • Click button 3, choose "Rome (Italy) Aerial" in the bottom combo box and click on the button located to the right of the combo box (with a little triangle).
Verify that an aerial image of Rome appears after a few seconds.
  • Click button 3, click one of the [...] buttons.
Verify that a simple file browser opens up.
  • By clicking on the folder names (one click) and on the "Parent folder" button, go to the folder /usr/local/share/ugvsigmobile
Verify that the file CapitolineHill_25833.shp is listed in the box to the right.
  • Select that file (click on it once) and click the green "OK" button.
  • Check the check box located immediately to the left of the file name (to make it visible on the map) and click on the button located to the right of the [...] button you clicked before (little triangle).
Verify that the map moves to a bean-shaped little shapefile that contains the Capitoline Hill in the center of Rome.
  • Click button 3 and uncheck the check box you checked before (to make the shapefile invisible).
  • Click button 5 and choose EPSG:3857 in the top combo box.
  • Click button 3, choose "OSM Mapnik" in the bottom combo box and click on the button located to the right of the combo box.
Verify that the Mapnik tiles appear on the map.
  • Open this URL (it's a simple WMS request) in a new web browser tab or window.
Verify that you see a map including Africa, South America and Europe, possibly with some colorful icons on it.
  • Click button 3 and check the check box tagged as "Waypts".
  • Click button 5 and click the "Sync" button.
Verify that after a few seconds you see a large dialog saying "Sync OK". Click the green (accept) button, which will take you to the map, where new red flags may have appeared.
  • Click button 1 several times until a red circle is visible on it.
  • Click somewhere on the map. A new dialog will show. Choose random values for the attributes and click the green (accept) button. Repeat this step two or three times.
  • Click button 5 and push the "Sync" button.
Verify that after a few seconds you see a large dialog saying "Sync OK".
  • Click the green (accept) button.
  • Go back to the web browser tab or window you opened before and click on "Refresh".
Verify that the points you added appear now on the map.
  • Click button 6 and click "Quit"
Verify that the application diappears.
  • Update the wiki with test results.

Test results from 13 March 2010
Run by: Juan Lucas Dominguez jldominguez
System: Arramagong livedvd 3.0 rc4 ISO within Virtual Box on Windows Vista
Version: Arramagong livedvd 3.0 rc4
Result: Pass

osgearth

Tests written for
osgearth, LiveDVD 3.0
Last updated
14 March 2010
Steps

  • Open a terminal
 osgearth_simple /usr/share/osgearth/maps/nexrad.earth
Result - test please

You should see a globe with radar data over some parts of North America.

click to navigate; right-click or scroll wheel to zoom in and out.

hit the 'escape' key to quit

gdal / ogr

Tests written for
GDAL, LiveDVD 3.0
Last updated
14 March 2010
Steps

  • Open a terminal
 ogrinfo PG:dbname=medford
 ogrinfo PG:dbname=medford -so -al
 gdalinfo /usr/share/osgearth/data/terrain/mt_rainier_90m.tif
Result

You should see a summary of the contents of the medford PostGIS database, and of a geoTIFF of Mt Rainier

MapGuide Open Source

Tests written for
MapGuide Open Source 2.2.0, LiveDVD 4.0
Test Description last updated
June 26, 2010
Steps
  • Start LiveDVD and log in as "user"
Verify presence of "MapGuide Start", "MapGuide Stop", and "MapGuide Maestro" desktop icons
  • Double click "MapGuide Start" desktop icon and enter "user" password if prompted
Verify that "Starting MapGuide" and "Starting Apache" messages appear
Verify that a map is displayed in the center of the screen with a layer legend to the left of the map and an application "Overview" pane to the right of the map.
  • Zoom into street level detail and click the pointer icon. Select a parcel.
Verify that a parcel is selected in blue.
  • On the right hand side of the page, click "Tasks" then "Buffer". Set the distance to 20 meters and click "Done"
Verify that a red buffer zone appears around the parcel.
Verify that the tree view contains "Samples/Sheboygan".
  • Update the wiki with test results (after these test steps)

test results from .date.
Run by: FirstName LastName
System: VMWare Player, 2Gig RAM, on ubuntu 9.0 base
Version: LiveDVD 4.0
Results: Pass, Pass with issues, Fail
  • link to bug reports

Add more test results below, most recent results at the top


Mapbender

Tests written for
Mapbender 2.6.1, OSGeo LiveDVD 4.0
Test Description last updated
5. July 2010
Steps
  • make sure that you have a working internet connection
  • make sure that your Apache and PostgreSQL is running
Verify that a browser opens after a few seconds showing the Mapbender login-page
  • login with user root / password root
Verify that the list of the available applications appears
  • choose application named "gui" with a click on the name
verify that the application "gui" opens and that you see a Mapbender application with the demis-world WMS, a germany WMS and a mapbender-user WMS
  • Update the wiki with test results (after these test steps)

test results from 5.7.2010
Run by: Astrid Emde
System: VirtualBox, 2Gig RAM, on ubuntu 8.10
Version: Mapbender 2.6.1, just ran ./install_postgis.sh and ./install_mapbender.sh
Results: Pass, Pass with issues, Fail
  • I ran ./install_postgis.sh and ./install_mapbender.sh - When I started Mapbender the ALIAS was not created. After restart the Mapbender could be used without problem, login succeded
Result
  • next test will be run with the osgeolive 4.0 rc

test results from 23.7.2010
Run by: Marc Manns
System: VirtualBox, 2Gig RAM, on ubuntu 8.10
Version: OSGeoLIve beta2 Mapbender 2.6.1
Results: Pass with issues
  • create user/group
  • create application
  • register new WMS
  • customize tree
  • add WMSFromFilteredList
  • change language in [Mapbender.conf] to german
  • suggestion: There is a password.txt at the desktop. I think, we should add our root/root authentication to it. -> done --astroide 09:28, 23 July 2010 (UTC)
Result
  • the Mapbender applications handling worked fine

Add more test results below, most recent results at the top


Ushahidi

Tests written for
OSGeo LiveDVD 4.0
Test Description last updated
-
Steps
  • see quickstart in doc/descriptions/ushahidi_description.html

Add more test results below, most recent results at the top


main documentation

Tests written for
arramgong_3.0rc4 + fixes
Test Description last updated
15 March 2010
Steps
  • Open Help by selecting he help icon (a yellow sign with a wombat)
Verify that the firefox web browser opens at file:///usr/local/share/livedvd-docs/index.thml
Verify that the browser opens with "Home", "Contents", "Contact and Support", "Tests", "Sponsors" tabs.
  • Click on the above tabs.
Verify the respective pages are opened.
  • Open the "Contents" tab
Verify that each project is mentioned.
Verify that the project version numbers matches version numbers here: http://spreadsheets.google.com/ccc?key=0Al9zh8DjmU_RdGIzd0VLLTBpQVJuNVlHMlBWSDhKLXc&hl=en_GB
Verify that when clicking on each project title, a description page is opened.
  • Install a link checker
sudo apt-get install linkchecker
  • Run the linkchecker against the installed docs:
linkchecker /usr/local/share/livedvd-docs/index.html 2>&1 | tee /var/log/arramagong/linkchecker.log
Verify there are not errors in the log file

test results from 13 March 2010
Run by: Cameron Shorter
System: VMWare Player, 2Gig RAM, on ubuntu 9.10
Version: arramagong 3.0 rc4 + fixes
Results: Pass with issues
  • When Firefox starts for the first time, it asks for confirmation for the language pack plugins
  • Errors found in the link check

Windows Installers

Tests written for
arramgong 3.0rc5
Test Description last updated
20 March 2010
Steps
  • From a windows computer, or Virtual Machine, insert the LiveDVD.
  • Go to the WindowsInstallers directory on the LiveDVD
Verify the installers are the same version number as the rest of the DVD, as listed at http://spreadsheets.google.com/ccc?key=0Al9zh8DjmU_RdGIzd0VLLTBpQVJuNVlHMlBWSDhKLXc&hl=en_GB
  • For each WindowsInstaller, run the installer, using all defaults
Verify the application installs without errors
  • If sufficient time, Open up the application and run the test steps above for the application.

test results from 20 March 2010
Run by: Jody Garnett
System: Windows XP, with a burned DVD and 1Gig RAM
Version: arramagong 3.0 rc5
Results: Pass with issues

As emailed here: http://lists.osgeo.org/pipermail/live-demo/2010-March/001595.html

FWTools243

  • ok

geonetwork-install-2.4.2-0

  • ok (is that a real version number?)

geoserver-1.7.6-ng

gpsbabel-1.3.6

  • zip file works
  • it would be nicer if the zipfile contained a folder (rather then just files so that users can unzip in one step rather then needing to make a folder first)

gpsVPxp_0.4.18

  • zip file works

gvSIG-update-1_1_2-windows-i586

  • failed
  • asks to install missing components
  • hitting yes tries downloading JavaJRE version 1.5.0...
  • .. and after 2 hours it did not succeed (and would not cancel)
  • system already had a jre6 installed (so above missing component should not of been needed)
    • Note: Updated to gvSIG 1.9 stable for arramagong 3.0RC6 and Final.

Kosmo_Desktop_2.0-RC1_windows_jre

  • zip file works fine

maptiler-1.0-beta2-setup

  • ok

MgServerSetup-2.0.2.3011

  • ok

ms4w_3.0-beta7

OpenCPN_136_Setup

  • ok

QGIS-1.4.0-1-No-GrassSetup

  • ok

udig-1.1.1

vcredist_x86

  • ok

WinGRASS-6.4.SVN-r41454-1-Setup

  • ok

Mac Installers

Tests written for
arramgong 3.0rc5
Test Description last updated
20 March 2010
Steps
  • From a windows computer, or Virtual Machine, insert the LiveDVD.
  • Go to the MacInstallers directory on the LiveDVD
Verify the installers are the same version number as the rest of the DVD, as listed at http://spreadsheets.google.com/ccc?key=0Al9zh8DjmU_RdGIzd0VLLTBpQVJuNVlHMlBWSDhKLXc&hl=en_GB
  • For each MacInstaller, run the installer, using all defaults
Verify the application installs without errors
  • If sufficient time, Open up the application and run the test steps above for the application.