Live GIS Disc Testing

From OSGeo
Jump to navigation Jump to search

This wiki describes how to test each application installed in the Live GIS Disc. Each section should contain enough information for an Ubuntu user who is unfamiliar an application to try it out and confirm that everything has been installed correctly.

template

Tests written for
.package. [version], arramgong [version]
Test Description last updated
.date.
Steps
  • .action.
Verify that ...
  • Eg: From menu, select GeoSpatial->Application->Start
Eg: Verify that a browser opens at url: http://localhost:... and shows the application start page.
  • Update the wiki with test results (after these test steps)

test results from .date.
Run by: FirstName LastName
System: VMWare Player, 2Gig RAM, on ubuntu 9.0 base
Version: distribution version: eg: arramagong 3.0 rc2
Results: Pass, Pass with issues, Fail
  • link to bug reports

Add more test results below, most recent results at the top

geoserver

gvsig

ugvsigmobile

Tests written for
Unofficial gvSIG Mobile for Linux 0.1.6, arramagong 3.0-rc2
Test Description last updated
3 March 2010
Steps
  • Click menu icon "Applications / Geospatial Beta software / Unofficial gvSIG Mobile for Linux".
Verify a new window opens up (size: 800 x 600 pixels approx.). From now on, buttons on the left side will be called (from top): button 1, button 2, button 3, button 4, button 5 and button 6. Button 1 is a cycle button with four different states corresponding to four different tools, so that active tool is the visible one.
  • Click button 5 and choose EPSG:25833 in the top combo box.
  • Click button 3, choose "Rome (Italy) Aerial" in the bottom combo box and click on the button located to the right of the combo box (with a little triangle).
Verify that an aerial image of Rome appears after a few seconds.
  • Click button 3, click one of the [...] buttons.
Verify that a simple file browser opens up.
  • By clicking on the folder names (one click) and on the "Parent folder" button, go to this folder:

/usr/local/share/ugvsigmobile

Verify that the file CapitolineHill_25833.shp is listed in the box to the right.
  • Select that file (click on it once) and click the green "OK" button.
  • Check the check box located immediately to the left of the file name (to make it visible on the map) and click on the button located to the right of the [...] button you clicked before.
Verify that the map moves to a bean-shaped little shapefile that contains the Capitoline Hill in the center of Rome.
  • Click button 3 and uncheck the check box you checked before (to make the shapefile invisible).
  • Click button 5 and choose EPSG:3857 in the top combo box.
  • Click button 3, choose "OSM Mapnik" in the bottom combo box and click on the button located to the right of the combo box.
Verify that the Mapnik tiles appear on the map.
  • Open this URL (it's a simple WMS request) in a new web browser tab or window.
Verify that you see a map including Africa, South America and Europe, possibly with some colorful crosses on it.
  • Click button 3 and check the check box tagged as "Waypts".
  • Click button 5 and push the "Sync" button.
Verify that after a few seconds you see a large dialog saying "Sync OK". Click the green (accept) button, which will take you to the map, where new red flags may have appeared.
  • Click button 1 several times until a red point is visible on it.
  • Click somewhere on the map. A new dialog will show. Choose random values for the attributes and click the green (accept) button. Repeat this step two or three times.
  • Click button 5 and push the "Sync" button.
Verify that after a few seconds you see a large dialog saying "Sync OK".
  • Click the green (accept) button.
  • Go back to the web browser tab or window you opened before and click on "Refresh".
Verify that the points you added appear now on the map.
  • Click button 6 and click "Quit"
Verify that the application diappears.
  • Update the wiki with test results.

geomajas

geonetwork

deegree

Tests written for
deegree 2.2, arramagong 2.0/3.0-rc2
Test Description last updated
4 March 2010
Steps
  • Click desktop icon "start deegree" which will run "catalina.sh start".
Verify firefox opens a new tab at the page http://localhost:8081/
  • Click the service links ("deegree-wms", "deegree-wfs", "deegree-wcs") in top left box ("deegree Web Applications").
Verify they open test pages for WMS, WFS, and WCS. These pages will contain links to
  • "GetCapabilities" (for each of the services)
  • "Test WMS", "Test WFS" or "Test WCS" (depending on the chosen service)
  • a link for the "Generic Client", a client for sending XML requests (http post) to the services.
  • Click on "TestW*S"
Verify you get either maps or xml fragments.
  • TestWMS will contain some images (results of WMS requests), and links for further KVP requests (http get).
  • TestWFS will open a page with several links for WFS requests (KVP). Either one will return XML fragments. There is also a link to the generic client.
  • TestWCS will open a page with several links for WCS requests (KVP). Either one will return XML fragments.
  • Click the client link ("deegree iGeoPortal") in top left box ("deegree Web Applications").
Verify this will open a new tab with a list of available WebMapContexts. Either one of these links (Utah, SaltLakeCity or Playground) should open a full working portal in this tab. Once the WMC is loaded you may switch to the other WMCs by using the drop down box labled "Theme selection"
  • Click on the desktop icon "stop deegree"
Verify the deegree-tomcat process is stopped.
  • click any of the links previously used: you will get a "Failed to Connect" message from firefox.
  • open a terminal and try ps fax | grep deegree. You should not get any results other than the grep itself.
  • Update the wiki with test results (after these test steps)

test results from 4 March 2010
Run by: Judit Mays
System: Virtualbox, ~600MB RAM, on ubuntu 9.0 base
Version: distribution version: arramagong-3.0rc2
Results: Pass

kosmo

udig

openjump

postgis

$ createdb -T template_postgis osm_barcelona
$ osm2pgsql -d osm_barcelona  /usr/local/share/osm/Barcelona.osm.bz2

Then try to view it in QGIS.

pgrouting

osm

JOSM
  • File → Open → /usr/local/share/osm/Barcelona.osm.bz2
Gosmore
  • Open a terminal
  • Import data with:
bzip2 -dc /usr/local/share/osm/Barcelona.osm.bz2 | gosmore rebuild

mapserver

geokettle

gmt

There are 29 example jobs built in, and a script to run them all:

  • Open a terminal
cp -r /usr/share/doc/gmt-examples/examples/ gmt-examples
cd gmt-examples/
./do_examples.sh

[whiz .. bang .. whirl]

View results: (type 'q' to quit gv)

for PLOT in `find . -name *.ps` ; do
   echo "$PLOT"
   gv "$PLOT"
done

Cleanup:

cd ..
rm -rf gmt-examples/

grass

Tests written for
grass 6.4.0rc5, arramagong 2.0/3.0
Last updated
March 2010
Steps
  • Double click on the GRASS desktop icon
Verify you see a slick "Welcome to GRASS" GUI
  • Select Spearfish60 for location, User1 for mapset
  • Click on [Start Grass]
  • In the Layer Manager GUI window add a raster layer
    • On the toolbar click the icon with a + and a checkerboard
    • On map to be displayed pull down the list and select elevation.dem
  • from the PERMANENT mapset and click [ok]
  • In the Layer Manager GUI window add a vector layer
    • On the toolbar click the icon with a + and a "V" line
    • For input map name pull down the list and select roads from the PERMANENT mapset and click [ok]
  • Over in the Map Display window toolbar click on the eyeball icon to render
Verify you see the maps displayed
See also
(North Carolina dataset is already installed in grassdata/)

qgis

FIXME
These instructions are not tested! Just off the top of my head.
open GeoTiff
  • where on the disc is one?
(if needed geotiff and shapefile export could be added to the GRASS testing procedure to make some)
open PostGIS data
(run the PostGIS test first so that the osm_barcelona DB exists!)
  • From the menu: Layer → Add PostGIS Layer ...
  • PostgreSQL Connections: [New]
Name: ________ "OpenStreetMap Import" 
Database: ____ "osm_barcelona"
  • Click on [Test Connect], with luck you will get a message that the connection to the database was successful.
  • Click [Ok] to close the New Database window.
  • Click on [Connect] in the top left of the Add PostGIS Table window. You should see a listing of tables come up.
  • Click on all of the table names to highlight them.
  • Click on [Add] at the bottom.
  • After some moments you should see the data displayed in the main map canvas.
  • Zoom, pan, query as you like.

This should at least prove to you that the database is correctly populated and running.

open shapefile
  • where on the disc is one?
  • From the menu: Layer → Add Vector Layer ...
Do not select New Vector Layer ... (that's for creating new data, not opening existing data)
  • Dataset: [Browse]
 ? where on disc ?
  • Ctrl-click on each of the *.shp files in that directory, then click [Open] and finally [Ok]
  • After some momements you should see the data displayed in the main map canvas.
  • Because the some of the shapefiles use a different map projection than the PostGIS database, things may not line up exactly. In the Settings → Projection Properties, Coordinate Reference System tab, you can tick the [•] Enable 'on the fly' CRS transformation box to overlay them. Be warned that this is computationally expensive and the layer may need to have its CRS set manually.
  • Zoom, pan, query as you like. Drag layer names up and down in the left-pane list to change their position in the stack.
open OSM data
  • need to enable plugin?
  • open /usr/local/share/osm/Barcelona.osm.bz2
Test the GRASS plugin
  • (it's installed, right?)
  • Go menu "Plugins, Pluginmanager, activate "GRASS plugin", OK button: a set of new buttons should appear
  • open location/mapset → ~/grassdata/spearfish90/PERMANENT
  • click "Add GRASS raster layer" button, select "elevation" map
  • click "Add GRASS raster layer" button, select "elevation_shade" map
  • click right mouse button in legend on "elevation_shade" map, move transparency to 40%
  • click "Add GRASS vector layer" button, select "roadsmajor" map, select layer "1-line" (level 1 is the topological level), OK

mapnik

maptiler

marble

Tested against ver 2.0
  • Click on the desktop icon
  • If you have used Google Earth before you should be able to figure this one out without much difficulty.
  • In the Settings menu select full-screen mode
  • Explore ...
  • In the bottom-left corner of the program window there is a subtle tab called "Map View". Click on it.
  • Select another map (e.g. 'Precipitation (July)')
  • Explore some more ...

octave

  • Open a terminal
  • Start program by typing "octave" at the prompt
% Which way to Barcelona from Sydney?
sydney = [-33.8750 151.2005]
barcelona = [41+23/60 2+11/60]

dirn = azimuth(sydney, barcelona);
deg_symb = 176;
disp(['Heading: ' num2str(dirn) deg_symb])
% How far's the trip? (roughly!)
system('proj -le')
wgs84_a = 6378137.0  % major radius of the Earth, in meters
dist_deg = distance(sydney, barcelona)
dist_meters = pi * wgs84_a * (dist_deg / 360.0)
disp(['Distance: ' num2str(dist_meters / 1000) ' km'])

Type "exit" to quit.

opencpn

Activate data
  • Open a terminal
  • Type "opencpn_noaa_agreement.sh" at the prompt
Run program

(assuming your GPS is not plugged in and gpsd is not running)

  • Double click the OpenCPN icon on the desktop or type "opencpn" at a terminal
  • Left-click recenters the view
  • Left-click-drag pans the view
  • Mouse-wheel zooms in/out
  • The blue bars in the bottom show previews of overlapping maps and clicking on them switches to them.
More details in the on-disc help page
and specifically the Getting Started help page.

geopublishing

gpsdrive

Testing

If no GPS is plugged in

  • Double click on the GpsDrive desktop icon
  • You should see a map of downtown Sydney, after about 10 seconds a waypoint marker for the Convention Centre should appear.
  • Set the map scale to 1:10,000 either by dragging the slider at the bottom or by using the +,- buttons (not magnifying glass)
  • Enter Explore Mode by pressing the "e" key or in the Map Control button.
  • Use the arrow keys or left mouse button to move off screen.
  • Right click to set destination and leave Explore Mode
Downloading maps
  • Change the scale setting to 1:1,000,000 you should see a continental map
  • Enter Explore Mode again ("e") and left click on the great barrier reef
  • Options -> Map -> Download
    • Map source: NASA LANDSAT, Scale: 1:500,000, [Download Map]
    • When download is complete click [ok] then change the preferred scale slider to 1:500,000
    • This will be of more use in remote areas.
  • Explore to the coast, click on an airport, headland, or some other conspicuous feature. You might want to use the magnifying glass buttons to zoom in on it better. Use a right click set the target on some other conspicuous feature nearby then demagnify back out.
  • Options -> Map -> Download
    • Map source: OpenStreetMap, Scale: 1:150,000, left-click on map to center the green preview over your target and what looks like a populated area.
    • [Download Map]
    • When download is complete click [ok] then change the preferred scale slider to 1:150,000 and you should see a (rather rural) road map. This will be more interesting in built up areas.
Overlay a GPX track
  • In the ~/.gpsdrive/tracks/ directory you will find australia.gpx which is a track line following the coastline.
  • Options -> Import -> GPX track
  • Hidden folders are hidden in the file picker, but just start typing ~/.gpsdrive and hit enter. You should then see the tracks/ directory and be able to load australia.gpx.
  • A red trace should appear along the coastline.
  • Check that it lines up well with the coast as shown in map tiles of varying scale.

If a GPS is plugged in

  • Make sure gpsd is running by starting "xgps" from the command line.
  • The program will automatically detect gpsd and jump to your current position. This should bring up a continental map as you won't have any map tiles downloaded for your area yet.
  • See the above "Downloading Maps" section to get some local tiles.
  • If you have a local GPX track of some roads try loading that and making sure everything lines up, as detailed in the above "Overlay a GPX track" section.

That's it.

mb-system

  • Open a terminal
cd /usr/local/mbsystem/examples/

List summary information about the contents of some bathymetric data files:

cd mbinfo/
./mbinfo.cmd

Grid some sample data and then view it:

cd ../mbm_plot/
./mbm_plot_5.cmd

# which creates this script:
./mbm_plot_test5.cmd

You should now see a nice plot of the seafloor off Baja California.

  • (this also acts as a test of the GMT plotting package)

mapfish

Tested against ver 2.0
  • Make sure you have a working internet connection
  • Double click on the Mapfish icon on the desktop
  • After a few seconds the web browser should open and you should see a map of the southwestern pacific
  • Click the magnifying glass just under the word "Map" at the top of the map.
  • Zoom in on Sydney
  • Explore

R

ossim

Main Documentation

  • Confirm that Firefox is opened at startup
  • Confirm that it opens up at file:///usr/local/share/livedvd-docs/index.html
  • Confirm that the homepage is set to file:///usr/local/share/livedvd-docs/index.html
  • Confirm that you can see descriptions about the different projects.