Live GIS Disc Testing

From OSGeo
Revision as of 05:22, 8 August 2010 by Astrid Emde (Talk | contribs) (Mapbender passed test with rc6)

Jump to: navigation, search

This page describes how to test each application installed on the Live GIS Disc. Application test steps describe how an Ubuntu user who is unfamiliar an application can try it out and confirm that everything has been installed correctly within 5 minutes. Test Results document when the application was last verified to be working.

This page is maintained at: http://wiki.osgeo.org/wiki/Live_GIS_Disc_Testing and copied onto each release of the LiveDVD.

  • Please try to move the app list into more of an alphabetical order ...

Contents

template

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.

Steps

Ideally, steps will reference Quick Start documentation, otherwise use following:

  • .action.
Verify that ...
  • Eg: From menu, select GeoSpatial->Application->Start
Eg: Verify that a browser opens at url: http://localhost:... and shows the application start page.
  • Update the wiki with test results (after these test steps)

Results from .date.

Run by: FirstName LastName
System: VMWare Player, 2Gig RAM, on ubuntu 9.0 base
Version: distribution version: eg: osgeo-live 4.0 rc6
Results: Pass, Pass with issues, Fail
  • link to bug reports

Add more test results below, most recent results at the top


Boot and Installer

Steps

Ideally, steps will reference Quick Start documentation, otherwise use following:

  • . Straight up Live DVD Disk
  • . Installer (into a VM if that is easier to clean up after)
  • . Testing is performed offline
Verify that ...
  • . You arrive at the desktop
  • . Help opens
  • . Firefox opens up
  • Update the wiki with test results (after these test steps)

Results from August 6th

Run by: Jody Garnett
System: Thinkpad T43, 2 GB, on live dvd
System: Macbook Pro, 4 GB, on live dvd
System: VirtualBox, 1 GB, 30GB HD image, on windows 7
Version: distribution version: eg: osgeo-live 4.0 rc6
Results: Pass with issues

Bootloader

  • . shows version 3.0
  • . think pad boots fine
  • . mac needed to hit ENTER to get to the initial boot loading screen

Installer

  • . tried with vitural box vm
  • . install says "Arramagong live"
  • . obviously installing will allow you to enter a user name; will this break applications expecting "user" ?
  • . my install failed; not enough space on the device. Need instructions indicating how much space is needed

Desktop

  • . think pad displays fine
  • . macbook pro - test OSGeo LIVE DVD Barcelona is cut off (and this one has higher resolution than many laptops)
  • . virtual box - could not adjust the screen resolution beyond the initial 800x600, instructions for open-vm-tools were fine, oh wait it wants a reboot - of a live dvd?
  • . never did get virtual box to have a different screen resolution even after adding the open-vm-tools

Suggestions from IRC:

  • . change background to not have text
  • . text at bottom of desktop being cut off is probably a function of screen aspect ratio
  • . indicate that "user" is the password in a box or make it more visible (good idea jasonbirch)
  • link to bug reports

Results from August 7th, 2010

Run by: Angelos Tzotsos
System: VirtualBox 3.2, 1Gig RAM, on OpenSUSE 11.2
Version: osgeo-live 4.0 rc6
Results: Pass with issues
  • The DVD has label Arramagong Live 3.0
  • User name is asked for installation, but after first boot, automatic login can be selected.
  • Had to install vbox-additions in order to change screen resolution.

deegree

Tests written for
deegree 2.3 , osgeo-live 4.0

Steps: Run the QuickStart.

Results from August 6th

Switch to running Quick Start over previous 3.0 test steps. Things working as expected.

Run by: Cameron Shorter
System: Virtual Box on Ubuntu
Version: distribution version: eg: osgeo-live 4.0 rc6
Results: Pass

Results from August 6th

Run by: Jody Garnett
System: Thinkpad, 2 GB ram, live dvd
Version: distribution version: eg: osgeo-live 4.0 rc6
Results: Pass with test script issues
  • start deegree not on desktop; has been moved … into Web Services
  • running start deegree opens firefox; firefox is in offline mode and can't browse http://localhost:8081/
  • services are there
  • test WMS, test WFS or test WCS links are not there
  • generic client works
  • deegree logo tries to take me to the website (and I am not online); I would like to return to the initial start page?
  • deegree iPortal does not exist
  • super hard to tell if the service stopped

Results from August 7th, 2010

Run by: Angelos Tzotsos
System: VirtualBox 3.2, 1Gig RAM, on OpenSUSE 11.2
Version: osgeo-live 4.0 rc6
Results: Pass with issues
  • Firefox starts before Tomcat + deegree are up, throwing a "not found" page. The user needs to refresh.
  • iPortal: When changing from Utah theme to Salt Lake City theme, the overview window is not redrawn.

atlasstyler

Run Quickstart

Quickstart:


Results from August 6th, 2010

Run by: Jody Garnett
System: Thinkpad T43, 2Gig RAM, on live dvd
Version: osgeo-live 4.0 rc6
Results: Atlas styler fail
  • . Application is in "Education > Atlasstyler" (Not Science > Atlas Styler)
  • . Quickstart is not specific enough; it is more a link to other docs
  • . Application "window" is messed up; the window tilebar is folded up under the desktop bar; you can resise the window; but not move it.
  • . Tried with natural_earth countries, a warning was provided that it would use the default style, progress bar is taking a long time
  • . Oh wait the tutorials link to their website (I am offline); but the styling layers with SLD tutorials in french and english are actually included on the disk (verified both links work)
  • . The application never came back to me; and the window issue result in a fail
  • . darn I was looking forward to this one
  • . figured out a workaround; clicking on task bar and asking the application to maximiz finally lets me get at the window tilebar
  • . Whew was able to use "ps -ef | grep java" and "kill" to shut it down

geopublisher

Run quickstart:

Tests written for Unknown
.package. [version], osgeo-live [version]
Test Description last updated
.date.
  • Go to applications->education-> and open Geopublishing documentation
    • Verify that the green page from file:///usr/share/doc/geopublishing/index.html open in a browser
  • Scroll to the bottom and click the demo atlas.
  • Unzip it do your Desktop
  • Go to applications->education-> and start Geopublisher
  • Load the atlas.gpa from your Desktop/ChartDemoAtlas
    • Verify that Geopublisher load the atlas. You should see a triparted GUI with a map-pool, data-pool and menu area.
  • Select File->Export and follow the wizard..
    • export online and offline version of the atlas to a new directory Desktop/ChartAtlasExported
    • When the export has finished, click the "open folder" button
    • Close Geopublisher
  • Go into the Desktop/ChartAtlasExported/DISK folder and run start.sh
    • Verify that an atlas opens
    • Verify that you see a "Charts available" button at the top right
    • Verify that clicking selecting the chart opens a chart window

Let that be the basic testing for Geopublisher now.


Results from August 6th, 2010

Run by: Jody Garnett
System: Thinkpad T43, 2Gig RAM, on live dvd
Version: osgeo-live 4.0 rc6
Results: Atlas styler fail
Results: GeoPublisher pass with issues
  • . Application > Education (not Science)
  • . You could just have the demo atlas link in the quickstart?
  • . I need a bit more advice no unzipping the demo atlas (firefox opened archive manager; but I think a picture is needed for those new to linux)
  • . Open Folder button did not work
  • . It is running and is very pretty

geoserver

Run quickstart: - http://download.osgeo.org/livedvd/4.0-rc6/osgeolive-docs/quickstart/geoserver_quickstart.html

Previous test definition:

  • Select the "Start GeoServer" icon.
  • Wait ~ 60 seconds for GeoServer to start.
Verify the GeoServer web page opens at http://localhost:8082/geoserver/web
  • In the firefox browser, click on "Layer Preview", wait ~ 30 secs
Verify you get a list of map layers
  • Select the 'OpenLayers' link on one of the layers (say the TOPP:States)
Verify you should see a web page with sample data in an interactive map

Results from August 6th,2010

Run by: Jody garnett
System: Thinkpad T43, 2Gig RAM, on live dvd
Version: osgeo-live 4.0 rc6
Results: Pass with issues
  • Quickstart document is not rendering correct; images rescale and text is pushed out of the way
  • Start GeoServer icon is not specific; it is in Web Services now; or in the Education menu (sigh!)
  • Nice progress bar as it starts up (who did that?)
  • Helpful having the start page link in the docs; but that new little progress bar opened the page for me
  • Suffers from the same "Firefox is in offline mode" error and cannot see local host (sent to email list)
  • No need to login if all you are doing is showing the layer preview
  • Warning is about the read-only file system; the live dvd provides this; so is this warning needed?
  • the directory needs to be /home/user/data/natural_earth (since the live dvd user name is "user" )
  • So adding a layer was fine; the sectino for adding the style to the layer is empty

Results from August 7th, 2010

Run by: Angelos Tzotsos
System: VirtualBox 3.2, 1Gig RAM, on OpenSUSE 11.2
Version: osgeo-live 4.0 rc6
Results: Pass
  • Embeded GeoWebCache WMS TMS document throws an error.
  • Quickstart: the path to find the data is /usr/lib/geoserver-2.0.2/data_dir/data instead of /usr/lib/geotools-2.0.2/data_dir/data

gvSIG

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.
  • Go to applications->education and start gvSIG
Verify that gvSIG starts correctly
  • Create a new view and add some shapefiles from /usr/local/share/mapserver/demos/itasca/data
Verify that the shapefiles are correctly added to the view
  • Create a new view and add any of the two TIFF files from /usr/local/share/mapserver/demos/itasca/data
Verify that the raster files are correctly loaded to the view
  • If you have Internet access, try to add a WMS layer from the combo list (i.e. the NASA JPL server)
Verify that a WMS layer can be accessed
  • Open the sample project included in the LiveDVD at /usr/local/share/gisvm/app-data/gvsig/sample-project.gvp
Verify the project loads all the data and layouts configured are available.
  • You can also try to access any of the other data available from the LiveDVD like the PostGIS Data, or WxS services by the map servers configured
This tests are related with the correct functioning of the other software installed on the LiveDVD
  • Update the wiki with test results (after these test steps)

Results from 6 Aug 2010

Run by: Christian Willmes
System: Virtualbox 3.2, 2048MB RAM, on Ubuntu 10.4
Version: distribution version: OSGeoLive-v4-rc6.7z
Results: pass with path issues to sample project
  • Programm runs fine, but on opening the sample project from /usr/local/share/gisvm/app-data/gvsig/sample-project.gvp, a file not found / Invalid path to "/home/user/data/openjump/data/departement22.shp" and the same message to a lot of other files in that directory comes up.

gdal / ogr

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.
Steps

  • Open a terminal
 ogrinfo --formats
 gdalinfo --formats
 
 ogrinfo data/natural_earth/10m_ocean.shp
 gdalinfo /usr/share/osgearth/data/terrain/mt_rainier_90m.tif

Results from August 7th, 2010

Run by: Angelos Tzotsos
System: VirtualBox 3.2, 1Gig RAM, on OpenSUSE 11.2
Version: osgeo-live 4.0 rc6
Results: Pass


geomajas

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.
  • Click desktop icon "Start Geomajas" which will start the Geomajas startup script. This will in turn start up a Tomcat server.
Verify firefox opens a new tab at the page http://localhost:3420/geomajas-tutorial/applications/tutorial/html/
  • Click on the "Start demo!" link for the Attributes & Features demo.
Verify that a sample demo page has opened with an application, showing the provinces of Belgium.
  • Doubleclick on one of the rows in the attribute table bottom right.
Verify that a floating window appears, showing the rows' contents in more detail.
  • Click on the desktop icon "Stop Geomajas".
Verify that the Tomcat server that runs Geomajas has stopped.
  • This can be done by refreshing the page. Firefox should give a warning that it is unable to connect.

Results from 9 March 2010

Run by: Pieter De Graef
System: Virtualbox, ~512MB RAM, on Windows XP
Version: distribution version: osgeo-live-3.0rc2
Results: Pass

Results from 6 Aug 2010

Run by: Christian Willmes
System: Virtualbox 3.2, 2048MB RAM, on Ubuntu 10.4
Version: distribution version: OSGeoLive-v4-rc6.7z
Results: fail
  • After starting 'start Geomajas' in the Browser Clients folder Firefox opens URL "http://localhost:3420/showcase/", which is a 404 Page delivered by Jetty.

Results from August 8th, 2010

Run by: Angelos Tzotsos
System: VirtualBox 3.2, 1Gig RAM, on OpenSUSE 11.2
Version: osgeo-live 4.0 rc6
Results: Fail

geonetwork

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.
  • Click icon "Start Geonetwork" - wait until the server intializes (see load graph in the upper right hand corner)
  • open FireFox http://localhost:8880
  • you should see a list of active URLs, choose /geonetwork

Results from .date.

Run by: FirstName LastName
System: VMWare Player, 2Gig RAM, on ubuntu 9.0 base
Version: distribution version: eg: osgeo-live 4.0 rc6
Results: Pass, Pass with issues, Fail
  • link to bug reports

Results from August 8th, 2010

Run by: Angelos Tzotsos
System: VirtualBox 3.2, 1Gig RAM, on OpenSUSE 11.2
Version: osgeo-live 4.0 rc6
Results: Pass

gpsdrive

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.

Testing

If no GPS is plugged in

  • Double click on the GpsDrive desktop icon
  • You should see a map of downtown Barcelona, after about 10 seconds a waypoint marker for the Convention Centre should appear.
  • Set the map scale to 1:150,000 either by dragging the slider at the bottom or by using the +,- buttons (not magnifying glass). After a moment you should see all 3 FOSS4G 2010 venues.
  • Enter Explore Mode by pressing the "e" key or in the Map Control button.
  • Use the arrow keys or left mouse button to move off screen.
  • Try clicking on the Workshop venue and mouse-wheel to zoom in on it
  • Right click to set destination and leave Explore Mode
  • Click on the "Find" button on the left
  • Set "maximum distance" to 1.0 km
  • Click the POI-Types drop down menu and select Food → Restaurant → Restaurant
  • Click the Find button in the top right
  • Click on the nearest restaurant, and "Select Target" in the bottom right
  • Make your way there and enjoy a nice meal
Downloading maps
  • Change the scale setting to 1:1,000,000 you should see the limits of the PostGIS/Mapnik/OpenStreetMaps road database for the conference area.
  • Click the "Map Control" button on the left hand side, and turn off Mapnik Mode.
You should now see a continental image
  • Enter Explore Mode again ("e") and left click on an island in the Med
  • In the top-left menu, pick Options → Map → Download
    • Map source: NASA LANDSAT, Scale: 1:500,000, [Download Map]
    • When download is complete click [ok] then change the preferred scale slider to 1:500,000
    • This will be of more use in remote areas.
  • Explore to the coast, click on an airport, headland, or some other conspicuous feature. You might want to use the magnifying glass buttons to zoom in on it better. Use a right click set the target on some other conspicuous feature nearby then demagnify back out.
  • Options -> Map -> Download
    • Map source: OpenStreetMap, Scale: 1:40,000, left-click on map to center the green preview over your target and what looks like a populated area.
    • [Download Map]
    • When download is complete click [ok] then change the preferred scale slider to 1:40,000 and you should see a road map. This will be more interesting in built up areas.
Overlay a GPX track
  • If you have a GPX track file lying around ...
  • Options -> Import -> GPX track
  • Hidden folders are hidden in the file picker, but just start typing ~/.gpsdrive and hit enter. You should then see the tracks/ directory and be able to load
  • A red trace should appear

If a GPS is plugged in

  • Make sure gpsd is running by starting "xgps" from the command line.
  • The program will automatically detect gpsd and jump to your current position. This should bring up a continental map as you won't have any map tiles downloaded for your area yet. (you may want to switch out of Mapnik Mode in the Map Control window)
  • See the above "Downloading Maps" section to get some local tiles.
  • If you have a local GPX track of some roads try loading that and making sure everything lines up, as detailed in the above "Overlay a GPX track" section.

That's it.

Results from .date.

Run by: FirstName LastName
System: VMWare Player, 2Gig RAM, on ubuntu 9.0 base
Version: distribution version: eg: osgeo-live 4.0 rc6
Results: Pass, Pass with issues, Fail
  • link to bug reports

geokettle

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.
Steps
  • Launch GeoKettle.
Verify you get a window prompting you to select a repository.
  • On the "Select a repository" dialog, choose "No repository".
Verify the GeoKettle application is opened.
  • Close any startup tips dialog.
  • Select File-> Open
  • Select /opt/geokettle/samples/transformations/geokettle/intersection.ktr
Verify you see the "intersection" transformation in the work area, with a big yellow comment box and some step icons.
  • Run the transformation in preview mode
    • Select Transformation menu -> Preview
    • Choose the "Intersecting rows" step (to view the rows that are outputted by that step)
    • then click on Quick Launch.
Verify you see the result in the "Examine preview data" dialog (two rows with four columns: GEOM1_ID, geom1, GEOM2_ID, geom2. The geom1 and geom2 fields should contain MULTIPOLYGON WKT geometries).

Results from .date.

Run by: FirstName LastName
System: VMWare Player, 2Gig RAM, on ubuntu 9.0 base
Version: distribution version: eg: osgeo-live 4.0 rc6
Results: Pass, Pass with issues, Fail
  • link to bug reports

gmt

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.

There are 29 example jobs built in, and a script to run them all:

  • Open a terminal
cp -r /usr/share/doc/gmt-examples/examples/ gmt-examples
cd gmt-examples/
./do_examples.sh

[whiz .. bang .. whirl]

View results: (type 'q' to quit gv)

for PLOT in `find . -name *.ps` ; do
   echo "$PLOT"
   gv "$PLOT"
done

Cleanup:

cd ..
rm -rf gmt-examples/

Results from 2010-08-06

Run by: Myles Kenihan
System: Live DVD, Base System Mac Mini 2.0 Dual Core 2Gig RAM
Version: osgeo-live 4.0 rc6
Results: Fail
  • do_examples command not found - I ran ls and it's there
--did you put ./ in front of the ./do_examples.sh? --HB

grass

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.
  • Double click on the GRASS desktop icon
Verify you see a slick "Welcome to GRASS" GUI
  • Select Spearfish60 for location, User1 for mapset
  • Click on [Start Grass]
  • In the Layer Manager GUI window add a raster layer
    • On the toolbar click the icon with a + and a checkerboard
    • On map to be displayed pull down the list and select elevation.dem
  • from the PERMANENT mapset and click [ok]
  • In the Layer Manager GUI window add a vector layer
    • On the toolbar click the icon with a + and a "V" line
    • For input map name pull down the list and select roads from the PERMANENT mapset and click [ok]
  • Over in the Map Display window toolbar click on the eyeball icon to render
Verify you see the maps displayed
See also
(North Carolina dataset is already installed in grassdata/)

Results from 2010-08-06

Run by: Myles Kenihan
System: Live DVD, Base System Mac Mini 2.0 Dual Core 2Gig RAM
Version: osgeo-live 4.0 rc6
Results: Pass

kosmo

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.
Steps
Theming layer with PostGIS backend
  • Select Geospatial > Desktop GIS > Kosmo in order to start Kosmo - Desktop
  • In the welcome dialog, select the option "With a new view" inside the "Create a new project" panel and click Ok
  • In the "Spatial Reference System selection" dialog, press the "..." button in order to select the view SRS
  • Select "EPSG" as Type
  • Enter 2270 in the textfield and click "Search" button; select the CRS given and click the Ok button
  • Click Ok again to set EPSG:2270 as the current view projection
  • In the main menu "View", select the option "Load Dataset..."
  • Select as Format -> "Database" (at the top-left corner) and "PostGIS" as database type
  • Enter Database Name: medford User Name: user Password: user and click the "Connect" button
  • Scroll down, check the box to the left of public.medford_zoning and click the Ok button
  • Select the medford_zoning layer at left under 'Working' and click the checkbox to make it visible
  • Right-click on the 'medford_zoning' layer and choose Simbology > Change Styles...
  • Select the "Colour Theming" tab; click the "Enable colour theming" checkbox
  • Choose Attribute => zoning and click the Ok button to apply the changes
  • You should see the zoning areas of Medford coloured by attribute in the map


Shapefile and image loading

  • Select Geospatial > Desktop GIS > Kosmo in order to start Kosmo - Desktop
  • In the welcome dialog, select the option "With a new view" inside the "Create a new project" panel and click Ok
  • Repeat the steps described in the test "Layer Theme with PostGIS backend", but selecting EPSG:26915 as the view projection
  • In the main menu "View", select the option "Load Dataset..."
  • Select as Format -> "Image file" and navigate to /home/user/data/mapserver/demos/itasca/ (or data/mapserver/demos/itasca/ if it starts at the home/user directory)
  • Select the directory "data" in order to load all the tiffs inside it as a mosaic and press the Ok button
  • Select the data layer at left under 'Working' and click the checkbox to make it visible
  • Select as Format -> "Shapefile" and navigate inside data directory
  • Select all the shapefiles and press the Ok button in order to load them
  • Check that all the shapefiles have been loaded on the layer tree at the left. Make them visible by clicking on the checkbox of each one



Results from .date.

Run by: FirstName LastName
System: VMWare Player, 2Gig RAM, on ubuntu 9.0 base
Version: distribution version: eg: osgeo-live 4.0 rc6
Results: Pass, Pass with issues, Fail
  • link to bug reports


mapnik

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.

see file:///usr/local/share/livedvd-docs/doc/mapnik_description.html Mapnik Description

--this may be 6 months old, try the on-disk quickstart instead --HB

Results from 2010-08-06

Run by: Myles Kenihan
System: Live DVD, Base System Mac Mini 2.0 Dual Core 2Gig RAM
Version: osgeo-live 4.0 rc6
Results: Fail
  • link to World Population Example app not present

maptiler

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.
  • you need an GeoTIFF or other raster geodata to test the functionality. So download for example this: http://download.osgeo.org/gdal/data/gtiff/utm.tif (when you use Firefox it will automatically save the files into ~/Downloads).
  • start MapTiler: click on "Applications" -> "Graphics" -> "MapTiler"
  • in the MapTiler application select on the first page "Google Maps compatible" tiles and click "Continue"
  • in the second page of wizard add the tiff, it should be ~/Downloads/utm.tif and click "Continue"
  • continue trough all other steps in the wizard (default options are fine) and then start "Render"
  • when the rendering is finished you will see a link to the directory with tiles, click to open it (it opens in Firefox as a directory)
  • open the "googlemaps.html", you should see a black&white overlay displayed on top of Google Maps hybrid layer. You can also open "openlayers.html" to see another presentation of the results.
Verify that ...
  • MapTiler application starts without problems when clicked on the icon
  • When you press on "Render" applications starts the processing and does not report any error.

Alternative "real" geodata for testing are for example USGS maps or NOAA RNCs.

Another way to try it:

  1. Start MapTiler by clicking the icon on the Desktop
  2. Load in the second step example raster GEODATA (with georerence/srs)
  3. Go trough all the steps with 'Next' up to the Render
  4. Once the render is finished you can click in the GUI to open a folder with tiles. When you open googlemaps.html or openlayers.html then you see your geodata warped to the overlay of popular interactive web maps as Google Maps.

The map tiles are displayed directly from your disk. To publish the map to Internet just upload the folder with tiles to any webserver or Amazon S3"


Results from .date.

Run by: FirstName LastName
System: VMWare Player, 2Gig RAM, on ubuntu 9.0 base
Version: distribution version: eg: osgeo-live 4.0 rc6
Results: Pass, Pass with issues, Fail
  • link to bug reports

marble

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.
  • Click on the desktop icon
  • If you have used Google Earth before you should be able to figure this one out without much difficulty.
  • In the Settings menu select full-screen mode
  • Explore ...
  • In the bottom-left corner of the program window there is a subtle tab called "Map View". Click on it.
  • Select another map (e.g. 'Precipitation (July)')
  • Explore some more ...

Results from 2010-08-06

Run by: Myles Kenihan
System: Live DVD, Base System Mac Mini 2.0 Dual Core 2Gig RAM
Version: osgeo-live 4.0 rc6
Results: Pass

mapfish

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.
Steps

  • Make sure you have a working internet connection
  • Double click on the Mapfish icon on the desktop
Verify that a browser opens after a few seconds showing a map of the southwestern pacific
  • Click the magnifying glass just under the word "Map" at the top of the map.
  • Zoom in on Sydney
  • Explore

Results from .date.

Run by: FirstName LastName
System: VMWare Player, 2Gig RAM, on ubuntu 9.0 base
Version: distribution version: eg: osgeo-live 4.0 rc6
Results: Pass, Pass with issues, Fail
  • link to bug reports

Results from August 8th, 2010

Run by: Angelos Tzotsos
System: VirtualBox 3.2, 1Gig RAM, on OpenSUSE 11.2
Version: osgeo-live 4.0 rc6
Results: Fail
  • Mapfish start-up script fails to start.

MapGuide Open Source

Tests written for
MapGuide Open Source 2.2.0, LiveDVD 4.0
Test Description last updated
June 26, 2010
Steps
  • Start LiveDVD and log in as "user"
Verify presence of "Start MapGuide", "Stop MapGuide", and "MapGuide Maestro" desktop icons
  • Double click "Start MapGuide" desktop icon and enter "user" password if prompted
Verify that "Starting MapGuide" and "Starting Apache" messages appear
Verify that a map is displayed in the center of the screen with a layer legend to the left of the map and an application "Overview" pane to the right of the map.
  • Zoom into street level detail and click the pointer icon. Select a parcel.
Verify that a parcel is selected in blue.
  • On the right hand side of the page, click "Tasks" then "Buffer". Set the distance to 20 meters and click "Done"
Verify that a red buffer zone appears around the parcel.
Verify that the tree view contains "Samples/Sheboygan".
  • Update the wiki with test results (after these test steps)

Results from August 5, 2010

Run by: Trevor Wekel
System: VMware ESX 4.1, 16GB RAM
Version: LiveDVD 4.0 RC 6
Results: Pass with minor issue - the project overview is missing. Cameron has already fixed it.
  • link to bug reports

Results from 6 Aug 2010

Run by: Christian Willmes
System: Virtualbox 3.2, 2048MB RAM, on Ubuntu 10.4
Version: distribution version: OSGeoLive-v4-rc6.7z
Results: pass with minor issue
  • The MapGuide Maestro points to the URL without the 8008 port after localhost, which results in an error, if the user does not fix this in the URL himself.

Mapbender

Tests written for
Mapbender 2.6.1, OSGeo LiveDVD 4.0
Test Description last updated
5. July 2010
Steps
  • make sure that you have a working internet connection
  • make sure that your Apache and PostgreSQL is running
Verify that a browser opens after a few seconds showing the Mapbender login-page
  • login with user root / password root
Verify that the list of the available applications appears
  • choose application named "gui" with a click on the name
verify that the application "gui" opens and that you see a Mapbender application with the demis-world WMS, a germany WMS and a mapbender-user WMS
  • Update the wiki with test results (after these test steps)

Results from 5.7.2010

Run by: Astrid Emde
System: VirtualBox, 2Gig RAM, on ubuntu 8.10
Version: Mapbender 2.6.1, just ran ./install_postgis.sh and ./install_mapbender.sh
Results: Pass, Pass with issues, Fail
  • I ran ./install_postgis.sh and ./install_mapbender.sh - When I started Mapbender the ALIAS was not created. After restart the Mapbender could be used without problem, login succeded
Result
  • next test will be run with the osgeolive 4.0 rc

test results from 23.7.2010

Run by: Marc Manns
System: VirtualBox, 2Gig RAM, on ubuntu 8.10
Version: OSGeoLIve beta2 Mapbender 2.6.1
Results: Pass with issues
  • create user/group
  • create application
  • register new WMS
  • customize tree
  • add WMSFromFilteredList
  • change language in [Mapbender.conf] to german
  • suggestion: There is a password.txt at the desktop. I think, we should add our root/root authentication to it. -> done --astroide 09:28, 23 July 2010 (UTC)
Result
  • the Mapbender applications handling worked fine

test results from 8.8.2010

Run by: Astrid Emde
System: VirtualBox, 2Gig RAM, on ubuntu 8.10
Version: OSGeoLIve rc6 Mapbender 2.6.2
Results: Passed
  • create gui
  • create application
  • register new WMS
  • print
Result
  • the Mapbender applications handling worked fine

Add more test results below, most recent results at the top


mb-system

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.
  • Open a terminal
cd /usr/local/mbsystem/examples/

List summary information about the contents of some bathymetric data files:

cd mbinfo/
./mbinfo.cmd

Grid some sample data and then view it:

cd ../mbm_plot/
./mbm_plot_5.cmd

# which creates this script:
./mbm_plot_test5.cmd

You should now see a nice plot of the seafloor off Baja California.

  • (this also acts as a test of the GMT plotting package)

Results from 2010-08-06

Run by: Myles Kenihan
System: Live DVD, Base System Mac Mini 2.0 Dual Core 2Gig RAM
Version: osgeo-live 4.0 rc6
Results: Pass

mapserver

Tests written for
MapServer 5.6.3, OSGeo LiveDVD 4.0
Test Description last updated
30 June 2010
Steps
  • Select the "MapServer" icon.
  • Wait a few seconds for FireFox to start.
Verify the MapServer web page opens at file:///usr/local/share/livedvd-docs/doc/mapserver_description.html
  • In the firefox browser, scroll down to "MapServer Demo" section and click on "Itasca".
Select "Basic Application" and click on "Initialize".
Verify you get a map.
  • Select the "Query multiple features" tool on the right of the page and click somewhere on the map.
Verify you get a list of features.
  • THE GMAP DEMO HAS BEEN REMOVE IN 4.0 ALPHA4, IT IS NOT YET COMPATIBLE WITH PHP 5.3 Return to the the initial MapServer web page, file:///usr/local/share/livedvd-docs/doc/mapserver_description.html , scroll down to "MapServer Demo" section and click on "GMap".
Verify you get a map and a legend with icons rendered.
  • Return to the the initial MapServer web page, file:///usr/local/share/livedvd-docs/doc/mapserver_description.html on the initial MapServer web page, scroll down to "MapServer Documentation" section.
Verify that the documentation version is appropriate versus the MapServer version.

Results from 2010-08-06

Run by: Myles Kenihan
System: Live DVD, Base System Mac Mini 2.0 Dual Core 2Gig RAM
Version: osgeo-live 4.0 rc6
Results: Pass with issues
  • All good, documentation link needs to be updated ( says 5.4.2 instead of 5.6, ) but docs themselves seem up to date

Results from 2010-08-06

Run by: Daniel Morissette
System: Live DVD on Acer AST180 desktop (AMD Athlon X2 64, 3GB RAM)
Version: osgeo-live 4.0 rc6
Results: Pass with issues
  • Itasca demo (and mapserv 5.6.5) work fine
  • Problems in mapserver_description.html
    • Need to remove "GMap" demo link (since GMap itself has been removed)
    • Need to update Documentation link to read "MapServer 5.6 Documentation" or even better: "MapServer Documentation" (with no version number so we don't need to update it in the future)
    • The main page of the MapServer 5.6 Docs that's on the DVD is from 5.6.3, and the OSM map in that page does not work: the link to the tiles point to a dead server. This is a known issue and the current version of the docs on the MapServer website (v5.6.5) have the map disabled... so it may be a good idea to grab the latest version of the 5.6 docs for the DVD.

Results from August 7th, 2010

Run by: Angelos Tzotsos
System: VirtualBox 3.2, 1Gig RAM, on OpenSUSE 11.2
Version: osgeo-live 4.0 rc6
Results: Pass
  • "GMap" demo link needs to be removed

octave

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.
  • Open a terminal
  • Start program by typing "octave" at the prompt
% Which way to Barcelona from Sydney?
sydney = [-33.8750 151.2005]
barcelona = [41+23/60 2+11/60]

dirn = azimuth(sydney, barcelona);
deg_symb = 176;
disp(['Heading: ' num2str(dirn) deg_symb])
% How far's the trip? (roughly!)
system('proj -le')
wgs84_a = 6378137.0  % major radius of the Earth, in meters
dist_deg = distance(sydney, barcelona)
dist_meters = pi * wgs84_a * (dist_deg / 360.0)
disp(['Distance: ' num2str(dist_meters / 1000) ' km'])

Type "exit" to quit.

Results from 2010-08-06

Run by: Myles Kenihan
System: Live DVD, Base System Mac Mini 2.0 Dual Core 2Gig RAM
Version: osgeo-live 4.0 rc6
Results: Pass

opencpn

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.
Activate data
  • Open a terminal
  • Type "opencpn_noaa_agreement.sh" at the prompt
Run program

(assuming your GPS is not plugged in and gpsd is not running)

  • Double click the OpenCPN icon on the desktop or type "opencpn" at a terminal
  • Left-click recenters the view
  • Left-click-drag pans the view
  • Mouse-wheel zooms in/out
  • The blue bars in the bottom show previews of overlapping raster maps and clicking on them switches to them. The green buttons switch to vectorial charts.
  • Right click on the map canvas to get a menu, select "Go to here".
  • At this point if you have your auto-pilot interfaced GPS plugged in you should feel your boat/airplane change course. If not, you'll see a red arrow and the destination target blinking anyway but will have make your own arrangements for getting there.
More details in the on-disc help page
and specifically the Getting Started help page.

Results from 2010-08-06

Run by: Myles Kenihan
System: Live DVD, Base System Mac Mini 2.0 Dual Core 2Gig RAM
Version: osgeo-live 4.0 rc6
Results: Pass

osm

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.
JOSM
  • File → Open → /usr/local/share/osm/Barcelona.osm.bz2
Merkaartor
  • Start it up from the Navigation and Maps menu
  • Click the "Download" button at the top left
  • Zoom in on Mataro just to the north of Barcelona (or anywhere) until one zoom level past where you can read the street names, and click [ok] to start the download
(download map: Left-click-drag to pan, mouse wheel to zoom)
  • Click on a road, see its attributes come up
  • now it's Right-click-drag to pan, mouse wheel to zoom
  • In the Layers list in the top-left right-click on "Map - None" and select "Yahoo!"
  • Click the little box to the left of "Map - Yahoo!" to enable the eyeball
  • Behold the satellite image underlay
Osmarender
  • Open up Merkaartor again
  • When satellite image comes up, click the "Download More" button
  • Once the streets come up do File → Export → OSM (XML)
  • Select "All visible", filename ~/test.osm
  • Quit Merkaartor
  • Open a terminal, then:
osmarender test.osm
[whiz-bang-whirl]
  • After some time it should finish leaving a test.svg file behind
  • Open the test.svg file in Inkscape or Firefox to view
inkscape test.svg
  • In inkscape it's middle-click-drag to pan, "+" key to zoom in
  • In Firefox use Ctrl-+ to zoom in
Gosmore
  • Open a terminal
  • Import data with:
bzip2 -dc /usr/local/share/osm/Barcelona.osm.bz2 | gosmore rebuild
  • Click on the "-" in the bottom-right of the map canvas until you see the city, then left click to center on downtown, mouse wheel up to zoom in
  • That's about it!

Results from 2010-08-06

Run by: Myles Kenihan
System: Live DVD, Base System Mac Mini 2.0 Dual Core 2Gig RAM
Version: osgeo-live 4.0 rc6
Results: Fail
  • Map didn't render to scale where I could find any roads. Probably because I'm not connected to network. Apps loaded up fine though
-- which app are you talking about? net connection should not be needed as we supply data in Barcelona.osm. for Merkaartor you need to un-bzip2 it first, see the quickstart for details. --HB

ossim

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.
Steps
Imagelinker
  • Start Imagelinker from its icon from the directory "Spatial Tools" on the desktop
  • Select the project file, using File -> Open Project -> /home/user/data/ossim/ossim_data/landsatrgb.prj
  • Go to the menu bar -> window -> tile
  • Select an image window -> select the pan icon -> click on the image -> press the button "propagate"
  • Verify you see a 3 gray satelite images.
OssimPlanet
  • Start OssimPlanet from its icon from the directory "Desktop-GIS" on the desktop
  • Select File -> Open Session -> /home/user/ossim/ossim_data/session.session
  • Navigate the scene.
  • Go to menu -> Open kml -> /home/user/ossim/ossim_data/*.kml
  • Go on the legend tree -> location -> open the trees -> bouble click on the kml location
you should see the scene zoom to the location
  • To test the command line simply run :
   ossim-image-info /usr/local/share/ossim/ossim_data/band1.tif

Note: to turn off the daylight auto-shading, un-check Preferences -> Environment -> Enable Ephemeris


Results from 2010-08-06

Run by: Myles Kenihan
System: Live DVD, Base System Mac Mini 2.0 Dual Core 2Gig RAM
Version: osgeo-live 4.0 rc6
Results: Fail
  • Couldn't find test file. no data/ossim directory
The above paths are out of date. look in the data/raster/ or data/kml/ dirs --HB

osgearth

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.
  • Open a terminal
 osgearth_simple /usr/share/osgearth/maps/nexrad.earth
Result - test please

You should see a globe with radar data over some parts of North America.

click to navigate; right-click or scroll wheel to zoom in and out.

hit the 'escape' key to quit


Results from 2010-08-06

Run by: Myles Kenihan
System: Live DVD, Base System Mac Mini 2.0 Dual Core 2Gig RAM
Version: osgeo-live 4.0 rc6
Results: Fail
  • command failed. Directory share/osgearth/maps/ does not exist

openjump

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.
Layer Theme with PostGIS backend
  • Open OpenJUMP
  • under the File menu select 'Open...'
  • select Data Store Layer
  • on the Connection line, click on the database icon (far right)
  • click on Add
  • enter Name: medford Server: localhost Port: 5432 Instance: medford User: user Password: user
  • click OK; click OK in the parent dialog box; you should be back in the Data Store Layer dialog
  • from the Dataset: menu choose 'medford_zoning'; click Finish
  • select the medford zoning layer at left under 'Working'
  • click on the Palette Icon in the menu bar
  • select the 'Colour Theming' tab; click 'Enable colour theming' checkbox
  • choose Attribute => zoning
  • choose a colour theme; click 'OK' to dismiss the dialog
  • you should see the zoning areas of Medford in various colours

Results from 2010-08-06

Run by: Myles Kenihan
System: Live DVD, Base System Mac Mini 2.0 Dual Core 2Gig RAM
Version: osgeo-live 4.0 rc6
Results: Fail
  • Open Jump started but database 'medford' doesn't exist
--test is out of date; run "psql -l" to list current installed PostGIS databases. --HB

postgis

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.
Spatial Query with the Graphical Query Builder helper
  • Open PGAdmin III from the Development menu
  • double-click on 'local'
  • under Databases, double-click on medford
  • open 'schemas'
  • open 'public'
  • select 'Tables', click on the 'Execute SQL' Icon above (it has a pencil in it)
  • expand the window and click on 'Graphical Query Builder'
  • open 'Schemas', double-click on 'public'
  • click and drag 'medford_wards' to the work area on the right
  • click and drag 'jacksonco_schools' to the work area on the right
  • choose 'jacksonco_schools' name, address, city and students
  • choose 'medford_wards' council_me (meaning council members)
  • click and drag from the_geom in 'medford_wards' to the_geom in 'jacksonco_schools' (you should see a solid line form with an '=' in it)
  • click on the 'SQL Editor' tab above, to navigate away from the Graphical Query Builder
  • edit the WHERE line to say
 ST_Contains( medford_wards.the_geom, jacksonco_schools.the_geom )
  • add an additional line
 ORDER BY medford_wards.council_me, jacksonco_schools.students DESC;
  • the entire query ends with one semicolon ';'
  • click on the 'execute query' icon above (a green triangle pointing to the right) you should see a list of council districts, schools, school sizes and the names of council members for each district as a result

Results from 2010-08-06

Run by: Myles Kenihan
System: Live DVD, Base System Mac Mini 2.0 Dual Core 2Gig RAM
Version: osgeo-live 4.0 rc6
Results: Fail
  • database 'medford' doesn't exist
--test docs are out of date. run "psql -l" to list currently installed databases. --HB

pgRouting

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.
  • Follow pgRouting Quick Start documentation, and confirm you get results described.

Results from 2010-08-06

Run by: Myles Kenihan
System: Live DVD, Base System Mac Mini 2.0 Dual Core 2Gig RAM
Version: osgeo-live 4.0 rc6
Results: Pass

qgis

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.
FIXME
These instructions are not tested! Just off the top of my head.
open GeoTiff
  • where on the disc is one?
(if needed geotiff and shapefile export could be added to the GRASS testing procedure to make some)
open PostGIS data I
  • From the menu: Layer → Add PostGIS Layer ...
  • PostgreSQL Connections: [New]
    Name: medford
    Host: localhost
    Database: medford
    Port: 5432
    username: user
    password: user
    SSL Mode: allow
   Test Connect should show success
   select sample point, line and poly layers
   view selected data
open PostGIS data
(run the PostGIS test first so that the osm_barcelona DB exists!)
  • From the menu: Layer → Add PostGIS Layer ...
  • PostgreSQL Connections: [New]
Name: ________ "OpenStreetMap Import" 
Database: ____ "osm_barcelona"
  • Click on [Test Connect], with luck you will get a message that the connection to the database was successful.
  • Click [Ok] to close the New Database window.
  • Click on [Connect] in the top left of the Add PostGIS Table window. You should see a listing of tables come up.
  • Click on all of the table names to highlight them.
  • Click on [Add] at the bottom.
  • After some moments you should see the data displayed in the main map canvas.
  • Zoom, pan, query as you like.

This should at least prove to you that the database is correctly populated and running.

open shapefile
  • where on the disc is one?
  • From the menu: Layer → Add Vector Layer ...
Do not select New Vector Layer ... (that's for creating new data, not opening existing data)
  • Dataset: [Browse]
 ? where on disc ?
  • Ctrl-click on each of the *.shp files in that directory, then click [Open] and finally [Ok]
  • After some momements you should see the data displayed in the main map canvas.
  • Because the some of the shapefiles use a different map projection than the PostGIS database, things may not line up exactly. In the Settings → Projection Properties, Coordinate Reference System tab, you can tick the [•] Enable 'on the fly' CRS transformation box to overlay them. Be warned that this is computationally expensive and the layer may need to have its CRS set manually.
  • Zoom, pan, query as you like. Drag layer names up and down in the left-pane list to change their position in the stack.
open OSM data
  • need to enable plugin?
  • open /usr/local/share/osm/Barcelona.osm.bz2
Test the GRASS plugin
  • (it's installed, right?)
  • Go menu "Plugins, Pluginmanager, activate "GRASS plugin", OK button: a set of new buttons should appear
  • open location/mapset → ~/grassdata/spearfish90/PERMANENT
  • click "Add GRASS raster layer" button, select "elevation" map
  • click "Add GRASS raster layer" button, select "elevation_shade" map
  • click right mouse button in legend on "elevation_shade" map, move transparency to 40%
  • click "Add GRASS vector layer" button, select "roadsmajor" map, select layer "1-line" (level 1 is the topological level), OK

Results from 2010-08-06

Run by: Myles Kenihan
System: Live DVD, Base System Mac Mini 2.0 Dual Core 2Gig RAM
Version: osgeo-live 4.0 rc6
Results: Fail
  • Problem with settings, says database medford does not exist
test docs are out of date. run "psql -l" to list currently installed PostGIS databases. --HB

Results from August 8th, 2010

Run by: Angelos Tzotsos
System: VirtualBox 3.2, 1Gig RAM, on OpenSUSE 11.2
Version: osgeo-live 4.0 rc6
Results: Pass with issues
  • The GRASS plugin could not load the data from the /hom/user/grassdata folder

R

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.
  • double click on the R Icon
  • at the command line, type demo(graphics) and hit return
  • follow the prompt and watch the target window for examples

If it is possible please add steps here to test the included geostats packages, they are both more interesting and more likely to have problems in the build. tx

e.g. something with r-cran-maps(.deb), gstat, sp, rgdal, or spgrass6 ?
#Load a library
library(sp)
#list the demos available
demo()
#Run the demo from the sp package
#This will step you through several examples of code and the resulting plots
demo(gallery)


Some examples to try here:

http://r-spatial.sourceforge.net/xtra/xtra.RHnw.html

Results from 2010-08-06

Run by: Myles Kenihan
System: Live DVD, Base System Mac Mini 2.0 Dual Core 2Gig RAM
Version: osgeo-live 4.0 rc6
Results: Pass

SAGA

Tests written for
OSGeo LiveDVD 4.0
  • Start the program
  • Check if no errors occur during initialisation (messages text)
  • Run the steps in the quickstart guide

As an extra test, you could check whether saga_cmd works: run SAGA_MLB=/usr/lib/saga saga_cmd from a terminal. The list of modules should be given. There should be 45 modules.

Results from 2010-08-05

Run by: Johan VandeWauw
System: Virtualbox, 700Mb RAM, on xubuntu 10.4 base
Version: distribution version: eg: osgeo-live 4.0 rc6
Results: Pass

Sahana

Tests written for
OSGeo LiveDVD 4.0
Test Description last updated
-
Steps
  • The 4.0rc6 release installer broke. Please rerun the gisvm/trunk/install_sahana.sh script as root before testing.

Results from 2010-08-06

Run by: Myles Kenihan
System: Live DVD, Base System Mac Mini 2.0 Dual Core 2Gig RAM
Version: osgeo-live 4.0 rc6
Results: Fail
  • Didn't have permission to run Sahana even when running under SUDO
--see above comment: it's not there because the installer failed. (now fixed) --HB

spatialite

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.
  • Open a terminal
spatialite /usr/local/share/spatialite/regions.sqlite
select r.NOME_REG, a.Nome from Aeroporti a, reg2008_s r where CONTAINS( r.Geometry, a.Geometry ) order by r.NOME_REG;
a graphical view of the same data
  • Run spatialite-gis

open file /usr/local/share/spatialite/regions.sqlite

Result - test please

You should see a set of Airports in Italy

Results from 2010-08-06

Run by: Myles Kenihan
System: Live DVD, Mac Mini 2.0 Dual Core, 2Gig RAM
Version: osgeo-live 4.0 rc6
Results: Pass with issues
  • should read user/data/spatialite/regions.sqlite
  • sql query doesn't work with 'order by' qualifier

udig

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.
Steps
  • open UDig
Verify you see a Welcome screen
  • Close the Welcome display. (Note if you don't close this display, then you can't load layers later on)
  • from the Layer menu, choose "Add..."
  • Choose Files from /home/user/data/udig/udig-data/data-v1_2/
  • select bc_border.shp
  • you may also select others, for example all shp files starting with bc_
  • click OK
Verify you see Canadian British Columbia data

Results from 2010-08-06

Run by: Myles Kenihan
System: Live DVD, Base system Mac Mini 2.0 Dual Core 2Gig RAM
Version: osgeo-live 4.0 rc6
Results: Fail
  • uDig opened but test data directory was not present

Raised issues:

Ushahidi

Tests written for
OSGeo LiveDVD 4.0
Test Description last updated
-
Steps

Add more test results below, most recent results at the top


Results from 2010-08-06

Run by: Myles Kenihan
System: Live DVD, Base System Mac Mini 2.0 Dual Core, 2Gig RAM
Version: osgeo-live 4.0 rc6
Results: Pass

Viking

Tests written for
OSGeo LiveDVD 4.0
Test Description last updated
-
Steps
  • Start it up from the Navigation and Maps menu
  • If you have a GPX file handy, File → Open
  • Layers → New Map Layer
  • pick OpenStreetMaps (Cycle), [ok]
  • On the Layer Name list on the left side, right click on "Map" and Download Onscreen Maps
  • It should start to download street maps of lower Manhattan
  • Select Tools → Ruler from the menu
  • Click on the Brooklyn Bridge, then on Batter Park to get a distance and heading

Results from 2010-08-06

Run by: Myles Kenihan
System: Live DVD, Base System Mac Mini 2.0 Dual Core 2 Gig RAM
Version: Osgeo-live 4.0 rc6
Results: Fail
  • Viking opened but with no gpx 'handy' I could not verify that it worked
--that's not really a fail. --HB

ZOO Project

Tests written for
.ZOO Project. 1.0.0, OSGeo LiveDVD 4.0
Test Description last updated
-
Steps
  • make sure that your Apache and GeoServer are running
  • click on "ZOO Project" icon from the Servers Desktop directory to make firefox loading the Spatialtools demo page
  • select a feature from the displayed states then click on a spatialtools buton to get the RawDataOutput result of processing displayed on the map

Results from 2010-08-03

Run by: Gérald Fenoy
System: VMWare Fusion, instance with 2Gig RAM and 2CPU
Version: distribution version: osgeo-live 4.0 rc6
Results: Pass

Results from 2010-08-03

Run by: Johan VandeWauw
System: Virtualbox, instance with 700Mb RAM
Version: distribution version: osgeo-live 4.0 rc6
Results: Pass after manual install - *if* geoserver started

zyGrib

Tests written for
OSGeo LiveDVD 4.0
Test Description last updated
-
Steps
  • click the magnifying glass 1:1 button on the toolbar to go to the world map
  • left-click drag a box over Europe
  • click the [] zoom button to the left of the 1:1 zoom button to zoom in to that box
  • click the power plug button on the right to check the server status
  • left-click drag an area of interest again
  • File → Download GRIB
  • click the [Download GRIB file] button in the lower-left, and save it.
  • You should now see a weather map
  • In the Data menu you can select different maps to look at
  • Click the rocketship button on the right end of the toolbar to see a 5 day animation of the forecast. Set speed, Play, etc.

Results from 2010-08-06

Run by: Myles Kenihan
System: Live DVD, Base System Mac Mini 2.0 Dual Core 2Gig RAM
Version: Osgeo-live 4.0 rc6
Results: Pass with issues
  • Could not connect to network so power plug failed. Could not retrieve network data

main documentation

Tests written for
.package. [version], osgeo-live [version]
Test Description last updated
.date.
Steps
  • Open Help by selecting he help icon (a yellow sign with a wombat)
Verify that the firefox web browser opens at file:///usr/local/share/livedvd-docs/index.thml
Verify that the browser opens with "Home", "Contents", "Contact and Support", "Tests", "Sponsors" tabs.
  • Click on the above tabs.
Verify the respective pages are opened.
  • Open the "Contents" tab
Verify that each project is mentioned.
Verify that the project version numbers matches version numbers here: http://spreadsheets.google.com/ccc?key=0Al9zh8DjmU_RdGIzd0VLLTBpQVJuNVlHMlBWSDhKLXc&hl=en_GB
Verify that when clicking on each project title, a description page is opened.
  • Install a link checker
sudo apt-get install linkchecker
  • Run the linkchecker against the installed docs:
linkchecker /usr/local/share/livedvd-docs/index.html 2>&1 | tee /var/log/osgeo-live/linkchecker.log
Verify there are not errors in the log file

Results from 2010-08-06

Run by: Myles Kenihan
System: Live DVD, Base System Mac Mini 2.0 dual core, 2Gig RAM
Version: osgeo-live 4.0 rc6
Results: Pass with issues


  • The following project listings had issues
  • 52 degree North Web Processing Service not present in contents
  • Geopublisher should be listed as version 1.5 in contents ( it's 1.4 )
  • Geoserver 2.0.1 should read 2.0.2
  • Mapbender not present in contents
  • Octave mapping tools not present in contents
--disabled on purpose. --HB
  • Open Jump 1.3 should read 1.3.1
  • R Geostatistics 2.10.1 should read 2.11.1
  • SAFA GIS not present in contents
  • uDIG 1.2rc1 should read 1.2rc3
  • Zoo Project not present in contents

The apt-get command failed because I was not connected to a network ( I'm not supposed to be connected to a network, apparently ) and also I was asked for a SUDO password which is not provided.

--sudo password now in welcome message --HB

The linkchecker could thus not be run as I was unable to acquire it


Windows Installers

Steps
  • From a windows computer, or Virtual Machine, insert the LiveDVD.
  • Go to the WindowsInstallers directory on the LiveDVD
Verify the installers are the same version number as the rest of the DVD, as listed at http://spreadsheets.google.com/ccc?key=0Al9zh8DjmU_RdGIzd0VLLTBpQVJuNVlHMlBWSDhKLXc&hl=en_GB
  • For each WindowsInstaller, run the installer, using all defaults
Verify the application installs without errors
  • If sufficient time, Open up the application and run the test steps above for the application.

Results from .date.

Run by: FirstName LastName
System: VMWare Player, 2Gig RAM, on ubuntu 9.0 base
Version: distribution version: eg: osgeo-live 4.0 rc6
Results: Pass, Pass with issues, Fail
  • link to bug reports


Mac Installers

Steps
  • From a Mac, or Virtual Machine, insert the LiveDVD.
  • Go to the MacInstallers directory on the LiveDVD
Verify the installers are the same version number as the rest of the DVD, as listed at http://spreadsheets.google.com/ccc?key=0Al9zh8DjmU_RdGIzd0VLLTBpQVJuNVlHMlBWSDhKLXc&hl=en_GB
  • For each MacInstaller, run the installer, using all defaults
Verify the application installs without errors
  • If sufficient time, Open up the application and run the test steps above for the application.

Results from 2010-08-06

Run by: Myles Kenihan
System: Booted from Disk. Base System Mac Mini 2.0 Dual Core, 2 Gig RAM
Version: Arramagong Live GIS 3.0
Results: Pass with issues

Could not run directly from OSX Snow Leopard. Had to change system settings to boot from disk which worked fine.