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Abstract

This module opens a set of FOSS GI S tutorials prepared by UMass group

1. Intro to Quantum GIS
Lab Setup

Get the data files

» Wewill use the following datasets for this lab: a) vector towns boundary for MA, b) vector landuse and roads data
for the Town of Amherst, MA, and c) 2 meter resolution orthophoto(s).

* Please download the dataset to a temporary folder on your computer from this location:
http://linux| ab.sbs.umass.edu/intro-fossgis-umass/datasets/lab_intro/IntroQGI SClassDemo.zip.

» This data was made available from the Massachusetts GIS repository (MassGIS) and is in United States State
Plane Coordinate System, Lambert Conformal Conic, NAD83, Massachusetts Mainland.

» Unzip datato your working directory. Y ou should see the following files appear:
¢ Orthophoto
e 2 117902.aux
e 2 117902.tfw
o 2 117902.tif
e Landuselayer
¢ lus8.dbf
o lusB.prj
 lus8.sbn
* lus8.sbx

* |usB.shp

[us8.shp.xml
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* lus8.shp

¢ Roadslayer
* rd5k8.dbf
 rd5k8.shp
* rd5k8.shx

e Townslayer
e TOWNS POLY .dbf
« TOWNS POLY .prj
e TOWNS_POLY .shn
« TOWNS_POLY .shx
« TOWNS POLY .shp
« TOWNS POLY .shx

*+ TOWNS_POLY_AREACODE.dbf

Getting Started: Let's look at the Menus of QGIS

1. Start up QGIS application.
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Figure 1. Main window
There are 5 major areas of QGIS main screen (Figure 1):
1. Table of Contents (layers) on the left
2. Map Overview Area
3. Standard Menu System
4. Zoom and other tools in the button row
5. Map area at the center (blank right now)
6. Status bar (area at the bottom of the application screen)
The status bar provides information on:
» gpatial extent
o scale2
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e current coordinates of cursor (Figure 2).

Spatial Extent Area Scale Cnnrdilnam Project Projection Settings
|_ | |
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Figure 2. Satus bar

Let's consider menu system and toolbars in detail .

Menu
QGIS has a standard menu system:

» File> New Project, Open Project, Save Project, Save Project As ..., Print, Export As Image, Export As Mapserver
file, Check QGIS Version

* View > Zoom to full extent, Zoom to selected features, Zoom to previous extent, Zoom to layer, Geospatial
bookmarks, New Geospatial bookmark, Refresh

» Layer > Add a Vector Layer, Add a Raster Layer, Add a PostGIS Layer, Remove Layer, New Vector Layer,
Toggle in Overview, Add All To Overview, Remove All From Overview, Show All Layers, Hide All Layers,
Attribute Table, Properties

» Settings > Project Properties, Custom Projections
* Plugins > Plugin Manager

» Help > Contents, QGIS Home Page, QGI S SourceForge Page

Icons

Look at the Icon Menus/Toolbars. The major toolbars buttons are described below (Figures 3-6)
| |=|E |8 | S|
l J_ Print

Save Project As..
Save Project
1 Open Project
Start a new QGIS Project

Figure 3. Sandard toolbar
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Figure 4. Tools for adding/removing/manipulating layers
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Figure 5. Toolbar (cont.)
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Geospatial Bookmarks
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Open attribute table for selected layer

Figure 6. Toolbar (cont.)

Using QGIS

Measure

Select features
|dentify a featurs

Capture Points/
Lines/Paolygons Tool

Recall that QGIS is atool for viewing, querying, editing, composing and publishing electronic maps. It combines
functionality for electronic mapping and spatial analysis. For those of you who have seen or used the ArcView 3.x

product, it's quite similar.

1. Start QGIS (if you don't have QGI S open)
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7.

8.

9.

. The main window will be blank, thisis an empty default project.

. To set project properties click "[Settings > Project Properties]” in the main menu. The "Project Properties’

window will appear.

. Click on the "[General]" tab and set Project Title and Map Units. Call this project Class Demo:QGIS and set the

Map Unitsto Meters.

. To set the projection of the project, click on the projection tab and find Projected Coordinate System, Lambert

Conformal Conic, and NAD83 Massachusetts Mainland.

. Click "[OK]" button to make changes. (Figure 6)

Propect Properies
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o Wegers _) Feet Therimal degrees

Figure 7. Setting project properties

First we will add a vector file.
Click on "[Add a Vector Layer]" button or select "Layer > Add a Vector Layer" in the main menu

A dialog window will appear. Please select alanduse layer (lus8.shp) from your working directory.(Figure 7).

s [ Aot i b i | = ] 2 [
=3

Figure 8. Adding a vector layer

10.Now let's display the raster file.

11.Click on "[Add a Raster Layer]" button or select "L ayer > Add a Raster Layer" in the main menu.

12.Select orthophoto file 2_117902.tif from your working directory and click [Open]

13.Y ou have two overlaying layers now in QGIS (Figure 8)
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Figure 9. Project layers added

14.If you don't have the raster image in your view, then select any layer in the Table of Contents (TOC) and click
the "Zoom to layer" menu button. The view should refresh itself and you will be able to see two data layers
(Figure 9).
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Figure . Refresh screen

15.Click on the raster file (2_117902.tif) and drag it down so that it is listed in the table of contents BELOW the
land use vector layer. Y ou should see the raster image covered with the land use layer (Figure 10).

16.If the land use layer does not cover the raster image select "View > Refresh”
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Figure 11. Changing order of layersin TOC

17.Note the coordinates from the map projection being used at the bottom, right hand corner and how they change as
you move the cursor around the map. Notice that the units of this coordinate system is meters.

18.To specify/change display units click Setting > Project Properties and click on [General] tab in the window
(Figure 10).

{{ [Hon-Comemancial] - Project Froperties

- Change map units
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Figure 12. Setting map units
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It'sagood habit to specify these settings when you start working on the project.

Now let's consider some map toals:

Map Tools

The map tools provide functions that help you navigate around the map.

[oN{oN(s ogiogr, Ae )G

last extent
Fan
Zoom to selected feature
Zoom to full extent
Zoom to layer
Zoom Out
Zoom In

Figure 13. Map tools

Specific tools:

e Zoom in and out (the magnifying tool + and -). This tool requires you to left-click and draw a rectangle around
the area that you want to zoom in on. Zoom in and notice how the map scale (at status bar) changes. GIS is
"scale-less’ which is why it is important as to what scales input maps were at so you don't try to use the GIS at
inappropriate scales!

» Zoom to layer. Select any layer in TOC and try this tool. Please, notice that map extent is set up to the selected
layer.

» Zoom to full extent. Thistool zooms in such way that all data are viewable in the map area.

Adding New Layers

» We have added one vector layer (land use) and the raster layer (orthophoto image).

» Usethe"Add Vector data' button to add road data layer (Rd5k8.shp) for the Town of Amherst.
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Add a Raster Layer
d a Vector Layer
Add a PostGIS Layer

Figure 14. Add Layer Tools

Change TOC information

Let's change the Table of Contents references:

* Right click on landuse layer entry: "'lus8pl.shp

Layers

E - LusBp1

Vector Layer

Zoom to extent of selected layer
Toggle In Overview

Remove
Open attribute table

Start editing
Stop editing

Figure 15. Opening properties window for a layer

e Choose Properties from the menu
» Layer Propertieswindow will appear

» Click onthe General tab
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Figure 16. General properties/tab

e Changethe Layer nameto Land Use

» Click "ok". The TOC entry should be changed.

» Change the color of this polygon layer to light green.

Display field = tile_name B:

» Double-click on the rectengul (or Right click on the layer and select Properties)

* Click on [Symbology] tab

Laver Propemes

/‘-Svnhnlogy—] General | Metadata | Labels [ Actions |

-Outline Style:

Legend type: : Single Symbol )—:-]
Label:
-Point
Symbol Q : Size [6 |+

H -

Qutline color:
QOutline Width:
Fill Colar:

-Fill Patterns:

LIS

7

SRR

Help

Figure 17. Symbology tab

(Applv) — ( Cancel :1

4
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Change the fill and outline colors of the polygon features.

Click [ok] and notice that color of land use layer was changed.

Whatever layer is at the top of the TOC will be displayed on top

Move the raster image to the top of the table of contents
 Click and hold on the 2_117902.tif image
» Drag this up to the top of the TOC

* You should see that some line and polygon features disappear because the raster grid is overlaying on the
vector layer

View Attribute Data

To look at the associated attribute database for the landuse features:
» Select Land Use Layer in TOC (put the layer on the top)

* Click on "Open Attribute Table" tool button.

 Scroll to theright to view various records of data

 Polygons represent different land use types. Fields [LU37_Code] and [LU21 Code] store codes of different land
use types.

CODE ABBREV CATEGORY DEFINITION

1 AC Cropland Intensive agriculture

2 AP Pasture Extensive agriculture

3 F Forest Forest

4 FW Wetland MNonforested freshwater wetland

5 M Mining Sand; gravel & rock

6 8] Dpen Land Abandoned agriculture; power lines; areas of no vegetation
7 RP Participation Recreation  Golf; tennis; Playgrounds; skiing

8 RS Spectator Recreation Stadiums; racetracks; Fairgrounds; drive-ins

9 RW Water Based Recreation Beaches; marinas; Swimming pools

10 RO Residential Multi-family

11 R1 Residential Smaller than 1/4 acre lots

12 R2 Residential 1/4 - 1/2 acre lots

13 R3 Residential Larger than 1/2 acre lots

14 = Salt Wetland Salt marsh

15 uc Commercial General urban; shopping center

16 Ul Industrial Light & heavy industry

17 uo Urban Open Parks; cemeteries; public & institutional greenspace; also vacant undeveloped land
18 uT Transpartation Airports; docks; divided highway; freight; storage; railroads
19 uw Waste Disposal Landfills; sewage lagoons

20 W Water Fresh water; coastal embayment

21 WP Woody Perennial Orchard; nursery; cranberry bog

22 - Mo Change Code used by MassGIS only during quality checking

Figure 18. Land use type codes

* Scroll down and select any record (Figure 15).
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‘ 806 .-,ﬂAttribute table - Land Use
. .//I Click to select record l Land use type
|id )_4.&( |perimeter ||u5_ Ilus_id |ti|e_name ||u_id
[i] B55560.362 1428.821 2 2 8
1 15968.664 570.973 E 3 8
2 7264588.500 67945.031 4 4 B

Figure 19. Selecting record in attribute table

» To seethe selected parcel(s) on the map, switch to the map view and click on the [Refr esh] button

© -

Figure 20. Refreshing selection set

» The selected parcels are shown in yellow color.

» Another way to see attribute information for a specific spatial feature (polygon, in our case), use [Info] tool
(Figure 17).

CEEIAET

ientify a feature on the active layer

Figure 21. Info tool

 Click on Info tool and then click on afeature (in the active layer) you are interested in.

« A window containing information for this feature will apear. Scroll down and note that it has the same fields as
the attribute table.

Measuring distances

L et's measure the distance between objects on the map. We will use M easure Tool for this operaton.

* Click onthe Measuretool (it's a button with picture of ruler on it).

4

Measure

o [i]]

Figure 22. Measure tool
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» Navigate a cursor over a feature and left click with a mouse to set a starting point. Select another point and click
again. A window showing segments length will appear

N Mieasure
T Tital
1041.98 3'31-1-1.";1-35
00066 6042.54;
1169.36 49212|
4210.97 13423
Help M e Close

Figure 23. Measure tool output

* Theresults will be in the map units you are working in. In this case, meters.

+ Continue to measure or right-click to stop.

Finishing the work
Saving amap as an image:
» Click File> Export Aslmage

» A dialog window will apper. You will need to specify file name and location, as well as to select image
format.JPEG and PNG are wide supported formats. So we would advise to save your map as jpeg or png files.
Then you can insert them into text document or presentation.

» To save the project, click [File > Save Project (As)]. The next time you can open the project in QGIS and QGIS
will restore your work status on the moment of saving. Note: Be sureto check wherethefile will be saved.

2. External Links

» Wikipedia articles on Image Formats: http://en.wikipedia.org/wiki/Image_formats

GDAL (Geospatial Data Abstraction Library): http://www.gdal .org [http://www.gdal .org/]

FW tools: http://fwtools.maptools.org/

MassGIS: http://www.mass.gov/mgis/
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3. Author Attribution

Major contributors to this curriculum include (al phabetical):
Maria Fernandez

Michael Hamel

Quentin Lewis

James Peters

Charlie Schweik

Alexander Stepanov

4. Module Licensing Information

Version 1.0. o
REA
HA s EHNE S
This exercise is licensed wunder a Creative Commons Attribution-ShareAlike 2.5 License
[http://creativecommons.org/licenses/by-sa/2.5/] and is being developed as a future contribution to the [Open
Geospatial Foundation's educational resources effort [http://wiki.osgeo.org/index.php/Educational_Resources]]. This
means that users are free to copy and share this material with others.

We intend to make this available in summer 2007 to the OSGeo community. Prior to this, we ask that you contact us
first if you would like to edit or make a new derivative of this content. Email address. cschweik AT pubpol DOT
umass DOT edu).

5. Reviewed by

Quentin Lewis

Retrieved from "http://linuxlab.sbs.umass.edu/intro-fossgis-umass/index.php?title=QGIS_overview"
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