Difference between revisions of "Live GIS Disc/Errata/10.5"

From OSGeo
Jump to navigation Jump to search
(GeoMoose 2,9,2 security notice)
 
(3 intermediate revisions by one other user not shown)
Line 1: Line 1:
DRAFT :
 
 
 
= Known Issues when 10.5 image went to press =
 
= Known Issues when 10.5 image went to press =
  
  
There is several known non-blocker issues at the 10.5 release. As we relay on projects teams to help us on fixing them, some might not have been corrected. Most of them are related to the 32bits version of OSGeo-Live, so we recommend to use the 64bits release. "''Sorry for the inconvenience''."
+
There are some known issues in the 10.5 release. As we relay on projects teams to help us on fixing them, some might not have been corrected. Some of them are related to the 32bit version of OSGeo-Live, so we recommend to use the 64bit release. "''Sorry for the inconvenience''."
  
If you can help us fixing those issues for next release, we will be really grateful.
+
If you can help us fixing those issues for next release, we would be really grateful.
  
 
* New bugs may be reported and known bugs viewed on the [https://trac.osgeo.org/osgeo/query?status=assigned&status=new&status=reopened&type=defect&component=LiveDVD&milestone=OSGeoLive10.5&col=id&col=summary&col=component&col=milestone&col=status&col=type&col=priority&order=priority OSGeo Trac system].
 
* New bugs may be reported and known bugs viewed on the [https://trac.osgeo.org/osgeo/query?status=assigned&status=new&status=reopened&type=defect&component=LiveDVD&milestone=OSGeoLive10.5&col=id&col=summary&col=component&col=milestone&col=status&col=type&col=priority&order=priority OSGeo Trac system].
Line 19: Line 17:
 
;Solution:
 
;Solution:
 
Change the basemap.
 
Change the basemap.
 +
 +
== GeoMoose ==
 +
;Problem:
 +
A security issue was found in the download.php script included with GeoMoose 2.9.2.
 +
This is an issue in an OSGeoLive environment if the web server is
 +
accessible from an untrusted network.
 +
 +
;Solution:
 +
Replace download.php with the version from GeoMoose 2.9.3.
 +
 +
https://raw.githubusercontent.com/geomoose/geomoose-services/r2.9.3/php/download.php
  
 
== Geonetwork ==
 
== Geonetwork ==
Line 25: Line 34:
 
Geonetwork does not work on 32bit iso (same as 10.0 release)
 
Geonetwork does not work on 32bit iso (same as 10.0 release)
  
 +
https://trac.osgeo.org/osgeo/ticket/1522
  
 
;Solution:
 
;Solution:
Line 32: Line 42:
  
 
;Problem:
 
;Problem:
GeoNode has a minor issue with demo layers loading but that will be fixed when we ship 2.6 for 11.0
+
GeoServer demo layers are not pre-loaded to GeoNode.
  
 
https://trac.osgeo.org/osgeo/ticket/1442
 
https://trac.osgeo.org/osgeo/ticket/1442
 
  
 
;Solution:
 
;Solution:
Line 46: Line 55:
  
 
https://trac.osgeo.org/osgeo/ticket/1900
 
https://trac.osgeo.org/osgeo/ticket/1900
 
  
 
;Solution:
 
;Solution:
The Atmosphere layer is visible.  
+
The Atmosphere layer is visible.
  
 
== PyWPS quickstart ==
 
== PyWPS quickstart ==
  
 
;Problem:
 
;Problem:
PyWPS quickstart does not work as expected due to configuration
+
PyWPS quickstart does not work as expected due to missing processing configuration files
  
 
https://trac.osgeo.org/osgeo/ticket/1886
 
https://trac.osgeo.org/osgeo/ticket/1886
 
  
 
;Solution:
 
;Solution:
Line 68: Line 75:
  
 
;Problem:
 
;Problem:
After testing 10.5rc2 32bit iso, rasdaman throws some exceptions on the demonstration page.  
+
rasdaman demonstration page throws service exceptions on the 32bit iso.  
  
 
https://trac.osgeo.org/osgeo/ticket/1902
 
https://trac.osgeo.org/osgeo/ticket/1902
 
  
 
;Solution:
 
;Solution:
 
Use the 64bits release.
 
Use the 64bits release.

Latest revision as of 08:41, 5 April 2017

Known Issues when 10.5 image went to press

There are some known issues in the 10.5 release. As we relay on projects teams to help us on fixing them, some might not have been corrected. Some of them are related to the 32bit version of OSGeo-Live, so we recommend to use the 64bit release. "Sorry for the inconvenience."

If you can help us fixing those issues for next release, we would be really grateful.

Cesium

Problem

The application works but the default bing basemap is not showing.

https://trac.osgeo.org/osgeo/ticket/1898

Solution

Change the basemap.

GeoMoose

Problem

A security issue was found in the download.php script included with GeoMoose 2.9.2. This is an issue in an OSGeoLive environment if the web server is accessible from an untrusted network.

Solution

Replace download.php with the version from GeoMoose 2.9.3.

https://raw.githubusercontent.com/geomoose/geomoose-services/r2.9.3/php/download.php

Geonetwork

Problem

Geonetwork does not work on 32bit iso (same as 10.0 release)

https://trac.osgeo.org/osgeo/ticket/1522

Solution

Try the 64 bits version

GeoNode

Problem

GeoServer demo layers are not pre-loaded to GeoNode.

https://trac.osgeo.org/osgeo/ticket/1442

Solution

Use custom layers.

Java World Wind

Problem

Some default layers are not shown by Java World Wind

https://trac.osgeo.org/osgeo/ticket/1900

Solution

The Atmosphere layer is visible.

PyWPS quickstart

Problem

PyWPS quickstart does not work as expected due to missing processing configuration files

https://trac.osgeo.org/osgeo/ticket/1886

Solution

Try the PyWPS official demo:

http://pywps-demo.readthedocs.io/en/latest/

rasdaman

Problem

rasdaman demonstration page throws service exceptions on the 32bit iso.

https://trac.osgeo.org/osgeo/ticket/1902

Solution

Use the 64bits release.